nyutasova
20.05.2023 13:33

Билет №31. НА ЯЗЫКЕ PYTHON, КТО СКОЛЬКО МОЖЕТ

1. Определить и вывести на экран цифры целого числа n. Например: 568(первая цифра справа равна 8,вторая цифра равна 6..)Решить задачу необходимо через цикл While и построить блок схему.
2. Написать программу определения максимального числа последовательности положительных чисел. Решить задачу необходимо через «Любой Цикл» и построить блок схему.
3. У гусей и кроликов вместе 64 лапы. Сколько может быть кроликов и сколько гусей (указать все возможные сочетания) Решить задачу необходимо через For и построить блок схему.
4. Посчитать все отрицательные числа, положительные возвести в 5 степень и вывести на экран. (Числа задаются датчиком случайных чисел в диапазоне от -43 до 15 ). Решить задачу необходимо через if и построить блок схему.
5. По номеру дня вычислить числа и месяца не високосного года. Решить задачу необходимо через Оператор выбора и построить блок схему.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
abc71
21.10.2022 02:26

#include<iostream>

using namespace std;

signed main() {

setlocale(LC_ALL, "Rus");

int N;

cin >> N;

int* a = new int[N];

for (int i = 0; i < N; i++)

{

 cin >> a[i];

}

//выводим индексы четных элементов

cout << "Номера тех элементов, значения которых чётны: ";

for (int i = 0; i < N; i++) {

 if (a[i] % 2 == 0)

  cout << i << " ";

}

//выводим весь массив

cout << "\nМассив: ";

for (int i = 0; i < N; i++)  

 cout << a[i] << " ";

return 0;

}

0,0(0 оценок)
Ответ:
nuraneferidxalideemi
28.12.2022 17:16
1)
 var 
n:integer;
begin 
readln(n); 
if(n<0)then write(0) 
else write(n+4);
end.

2)
 var
  a, b: integer;
 begin
  readln(a, b);
  if(a = b) then
write(1)
  else
write(0);
end.

3)
var
  a, b, c, s: integer;
 begin
  s := 0;
  readln(a, b, c);
  if(a >= 0) then s := s + 1;
  if(b >= 0) then s := s + 1;
  if(c >= 0) then s := s + 1;
  write(s);
end.

4)
var
  a, b, c, s: integer;
 begin
  s := 0;
  readln(a, b, c);
  if(a > 0) then s := s + a;
  if(b > 0) then s := s + b;
  if(c > 0) then s := s + c;
  write(s);
end.
5)
 var
  a, b, c: integer;
 begin
  readln(a, b, c);
  if (a < b) then swap(a, b);
  if (a < c) then swap(a, c);
  if (b < c) then swap(b, c);
  write(a, ' ', b, ' ', c);
end.

6)
 var n, k, s, i: integer;
 begin
  s := 0;
  readln(n, k);
  for i := 1 to n.ToString.Length do
  if(strtoint(n.ToString[i]) > k) then s := s + strtoint(n.ToString[i]);
  write(s);
 end.

7)
 var n, s, i: integer;
 begin
  s := 0;
  readln(n);
  for i := 1 to n do
    s := s + i;
  write(s);
 end.

9)
 var n, i: integer;
 begin
  readln(n);
  for i := n downto 1 do
  write(i);
 end.

12
 var
  n, i: integer;
  s: real;
 begin
  s := 0;
  readln(n);
  for i := n downto 1 do
  s:=s+(0.1*i);
    write(s);
 end.

13)
 var n, i: integer;
 begin
  readln(n);
  for i := 1 to n do
    write(sqr(i), ' ');
end.

14)
 var
  n, i, c: integer;
 begin
  i := 1;
  c := 0;
  readln(n);
  while (c <> n) do
  begin
    if(i mod 3 = 0) then begin write(i, ' ');c := c + 1; end;
    i := i + 1;
  end;
end.

15)
 var
  n, i, a: integer;
  c: real;
 begin
  i := 1;
  c := 0;
  readln(n);
  for i := 1 to n do
   begin
    read(a);
    c := c + a;
  end;
  write(c / n)
end.

16)
 var
  n, i, a: integer;
 begin
  i := 1;
  while true do
   begin
    read(a);
    if(a = 0) then break;
    n := n + 1;
  end;
  write(n)
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота