SarJiG2A
13.12.2021 02:33

Напишите программу для графического исполнителя Basic Графические исполнители соответствуют стандартному языку Бейсик.
1. Line (x1,y1)-(x2,y2),c - отрезок по двум точкам.
2. Line- (x,y),c - отрезок от текущей точки до точки (x,y).
3. Line (x1,y1)-(x2,y2),c,b[f] - прямоугольник [закрашенный прямоугольник].
4. Circle (x,y),r,c - окружность радиусом r.
5. Paint (x,y),c1,c2 - закрашивание замкнутой области цветом c1 до цвета c2
6. Draw "командная строка" (u - вверх, d - вниз, l - влево, r - вправо, e - вверх и вправо,
f - вниз и вправо, g - вниз и влево, h - вверх и влево, m - движение в указанную точку,
n - двигаться и вернуться в исходную точку, b - движение, но не рисование, c - установка
цвета).

Цвета обозначаются числами от 0 (черный) до 15 (белый).

Строка с коментарием начинается с символа ОПОСТРОФ ( ' ).

Реализована возможность использования двух видов направления оси Y.

Команда (оператор) присваивания реализована в усеченном варианте.
Допускаются простейшие выражения следующих видов с использованием сложения,
вычитания, умножения и деления..
1 вид: Переменной присваивается числовое значение (x = 100).
2 вид: Переменной присваивается значение другой переменной (x = y).
3 вид: Переменной присваивается простейшее выражение (y1 = y1 +50, y = x - n).

На имена переменных наложено ограничение: Имя переменной может состоять из
ОДНОЙ латинской буквы или из ОДНОЙ латинской буквы и ОДНОЙ цифры.
Примеры имен переменных: x, a5, y8, d.

Пока, в этой версии программы, переменные и выражения с переменными могут
использоваться только в исполнителе Line. Допускаются простейшие выражения трех видов
с использованием сложения и вычитания.
1 вид: Переменная: Line- (x,y).
2 вид: Переменная + или - числовое значение: Line- (x+50, y-50).
3 вид: Переменная + или - переменная: Line- (x+n, y-n).


Напишите программу для графического исполнителя Basic Графические исполнители соответствуют стандарт

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
MeilisS
01.11.2022 05:23
В общем случае, трассировка - один из отладки программ врукопашную: состояние программы контролируется на определённом отрезке времени её выполнения путём анализа значений переменных. трассировка в том или ином виде при отладке программ сложнее школьного дз практически неизбежна.
в простейшем случае, трассировка - вывод значений переменных на экран (например, в окно консоли) , либо расчёт их на бумажке для каждого шага.
в более продвинутом варианте используются точки останова, окно наблюдения, выполнение по шагам и, если есть, контекстный интерпретатор выражений.
есть также специальная "трассирующая консоль" - интерфейс вывода информации из программы в отладчик, если таковой присутствует.
почти любой современный отладчик показывает состояние програмm при её останове, что делает трассировку процессом легко доступным
0,0(0 оценок)
Ответ:
Вазген228
05.05.2020 01:59
Алгоритм
1) a x a = a² ⇒ b;    b x a = a³ ⇒ результат
2) a x a = a² ⇒ b;    b x b = a⁴ ⇒ c;   c x c = a⁸ ⇒ c;   c x b = a¹⁰ ⇒ результат

Программа на языке PascalABC.Net
var
  a,b,c,y:real;
begin
  Write('Введите число: '); Read(a);
  b:=a*a; y:=b*a; Writeln('Третья степень числа равна ',y);
  c:=b*b; c:=c*c; y:=b*c;
  Writeln('Десятая степень числа равна ',y)
end.

Тестовые решения:
Введите число: 2
Третья степень числа равна 8
Десятая степень числа равна 1024

Введите число: -13.594
Третья степень числа равна -2512.128188584
Десятая степень числа равна 215512594781.574
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота