diamiss45
18.06.2021 08:33

составить программу по информатике. Дано предложение. Вычислить сколько в нем разных(неповторяющихся) знаков препинания.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
2508sanya
03.01.2021 11:59

Пример решения задачи на языке PascalABC:

var

 J:Array of Char:=('.','!','?',',',';',':','-','(',')','"');

 T:=0;

begin

 var s:string; readln(s);

 var N:=S.ToCharArray;

 for var l:=1 to J.High do

   if N.FindAll(x->(x = J[l]) = true).Length <> 0 then inc(T);

 write('В предложении ',(T<>0)? T.ToString:'не содержится',' уникальных знаков препинания');

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота