nikakrasovska
19.03.2022 12:24

составить программу С++, используя оператор FOR. 1 У гусей и кроликов вместе 64 лапы. Сколько может быть кроликов и гусей (указать все сочетания и количество вариантов)?
2 Составить программу, используя оператор FOR.
Составить программу для определения N! – M!, где N!=1*2*3*…*. N . N и М задает пользователь

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Anilecchi
04.01.2021 17:28

1)

#include <iostream>

using namespace std;

int main()

{

int g, k, n=64;

for (g=0; g<=n; g++)

{

for (k=0; k<=n/2; k++)

{

if (2*g + 4*k == n)

{

printf ("Gycu - %d. \nKpoluk - %d.\n\n", g, k);

}

}

}

return 0;

}

2)#include <iostream>

using namespace std;

long double fact(int N)

{

if(N < 0)

return N;

if (N == 0)

return 1;

else

return N * fact(N - 1);

}

int main()

{

int N, M;

setlocale(0,"");

cout << "N=";

cin >> N;

cout<<"M=";

cin>>M;

cout<<"N!-M!=" << fact(N)-fact(M) << endl << endl;

return 0;

}

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота