Аносип
09.10.2022 01:45

с заданиями по программированию на При программировании на языке C++ рекомендуется изучить функции system(), sprintf(), atoi().
8.2 Написать программу, которая вычисляет квадрат числа и выводит результат на экран. Входные данные должны сообщаться как параметр командной строки.
Инициатор вычислений: [*.bat]–файл со следующим содержимым:
@SET /A A = 3
prog %A%
pause
где prog – имя исполняемого [*.exe]-файла разработанной программы, а 3-число, для которого проводятся вычисления.
8.3 Дана программа №1, код которой приведён в [*.bat]–файле:
@SET /A A = %1
@SET /A A += 5
@EXIT %A%
Здесь число, являющееся первым переданным программе параметром командной строки, увеличивается на 5, и полученный результат формируется как возвращаемое значение программы.
Написать программу, в которой введённое пользователем число передаётся для вычислений в программу №1 и полученный ей результат выводит на экран.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
ГолубойРо
09.07.2020 16:39
Program egor_sasha; var num_eg, num_sash,pri,pri1: real; var mes_eg,mes_sash: real; beginwriteln('numer egora'); readln(num_eg); writeln('numer sashi'); readln(num_sash); writeln('mesto egora (verkh=1,vniz=0)'); readln(mes_eg); writeln('mesto sashi (verkh=1,vniz=0)'); readln(mes_sash); pri: =num_sash+1; pri1: =num_eg+1; if num_eg=pri then    writeln('yes')  else writeln('no'); if num_sash=pri1 then    writeln('yes')  else writeln('no'); if mes_eg=1 then    writeln('egor-high')else  writeln('egor-low'); if mes_sash=1 then    writeln('sasha-high')else  writeln('sasha-low'); end.
0,0(0 оценок)
Ответ:
srySyutoduofyi
05.03.2020 05:03
Количество информации в сообщении обычно равно количеству бит (округляемому до ближайшего целого с избытком) , которое необходимо для воспроизведения текста сообщения. то есть в сообщении 10101010 информации - 8 бит, в сообщении "погода сегодня будет зимняя, снег не растает, солнце взойдет утром и сядет вечером" - 350 бит (если считать, для простоты, что в языке 32 буквы) . в сообщении e=hν информации, если кодировку ситать юникодом, - 8 байт (64 битa) информации. но вот ценность этих сообщений несопоставима.  но ценность информации не есть величина неизбывная и строго измеряемая для данного сообщения. она всегда зависит от того, кому эта информация предназначена, и от того, что путного можно извлечь из неё, а значит - слабо формализуема. в конце концов, запросто можно представить себе (путь и фантастическую) 
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота