YNOCHKA2008
31.01.2022 13:39

На с++ Напишите программу, которая строит матрицу смежности графа на основе списков смежности для каждой вершины.

Входные данные
В первой строке вводится количество вершин графа N ( 1 ≤ N ≤ 1000 ). В следующих N строках записаны списки смежности для каждой вершины – номера вершин, в которые существуют исходящие рёбра из данной вершины.

Выходные данные
Программа должна вывести матрицу смежности для заданного графа.

Примеры
входные данные
5
2 3 4
1 3 5
1 2 4
0
2 4
выходные данные
0 1 1 1 0
1 0 1 0 1
1 1 0 1 0
0 0 0 0 0
0 1 0 1 0

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
margo2606
14.04.2020 12:03
(.. или ..) и (..или ..)Скобки означают о приоритете - какое выражение выполнять первым. В данном случае у нас 3 действия: 1,2 по порядку слева направо с операцией ИЛИ, а так же 3 с И.И - это коньюнкция (логическое умножение), оно верно только в том случае, если оба выражения являются истинными.ИЛИ - дизъюнкция (логическое сложение), оно верно, если хотя б одно выражение является истинным.Давайте решим Ваш пример:9999999 - это максимальное семизначное число, давайте подставим его в примере и приведём к нужному виду.Я выбрал "есть хотя бы одна четвёрка" И "нет восьмерок", в результате самое максимальное семизначное число, которое подойдёт к данному условию - 9999994
0,0(0 оценок)
Ответ:
Gaky
11.09.2020 15:07
Using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.Threading.Tasks;

namespace pzn
{

    class Program
    {
       public static void Main(string[] args)
        {
            int x = Convert.ToInt32(Console.ReadLine());
            int y = Convert.ToInt32(Console.ReadLine());
            int temp;
            if (x<y)
            {
                x ^= y;
                y ^= x;
                x ^= y;    
            }
            Console.WriteLine("x={0}, y={1}", x, y);
            Console.ReadKey();
        }
    }
}
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота