Викуша0402
31.01.2022 06:33

Цель: Научиться вводить линейные программы. Познакомиться со стандарными функциями линейных программ QBasic.
1. Задание : Составить программу для подсчета значений функции:
y=0.3X2
-1.25X
3+5.64X-8.3,
при Х=0.5;
Х=-8,126;
Х= 0.0015.
Наберите готовую программу и в отчет запишите результат вычислений.
INPUT X
LET Y=(0.3*X^2-1.25*X^3+5.64*X-8.3)
PRINT “X=”;X,”Y=”;Y

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
davas255
24.06.2022 10:33

var  

  arr:array[1..1000] of integer;

  i,N:integer;

  max:integer;

begin

   max:=1;

   

   write('Укажите кол-во эл-ов - ');

   

   read(N);

   

   for i:=1 to N do//Присваивание и вывод массива

   begin

       arr[i]:=1+random(100);

       

       write(arr[i],'  ');

       

       if arr[i]>max then max:=arr[i];

   end;

   

   writeln;

   

   writeln('Максимальный эл-т - ',max);

   

   for i:=1 to N do//Увеличение чет. эл-ов

     begin

     if arr[i] mod 2=0 then arr[i]:=arr[i]+max;

     

     write(arr[i],'  ');

     end;

 

end.

Объяснение:

0,0(0 оценок)
Ответ:
fortunazanna
17.02.2023 07:04

1. Для записи алгоритмов используют несколько словесный

графический

программный

Словесный – это записи алгоритма на естественном языке, но с тщательно отработанным набором слов и фраз, не допускающих повторений, синонимов, двусмысленности, лишних слов. Допускается использование математических символов. При графическом описания алгоритма осуществляется с блок-схем. Программный это запись алгоритма на языке программирования (в виде компьютерной программы).

2. Налить 9 литров. Перелить в другое ведро 5 литров. В 9-ти литровом останется 4 литра. Из 5-ти литрового вылить воду. Перелить из 9-ти литрового оставшиеся 4 литра в 5-ти литровое ведро. Наполнить 9-ти литровое ведро водой. Перелить в 5-ти литровое ведро 1 литр (больше в 5-ти литровое не влезет). Из 5-ти литрового вылить воду. В 9-ти литровом останется 8 литров. Перелить в 5-ти литровое ведро. ИТОГ: в 9-ти литровом останется 3 литра.

3. Прямоугольник - блок вычислений

Ромб - условие

Параллелограмм - блок ввода-вывода данных

овал - начало и конец алгоритма

Стрелки, соединяющие эти фигуры, и задают порядок выполнения действий.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота