dyumaevanastasy
01.04.2022 07:15

Паскаль. Решать с применением цикла с постусловием Написать программу паскаль табулирования функции на заданном промежутке с шагом 0.2


Паскаль. Решать с применением цикла с постусловием Написать программу паскаль табулирования функции

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Gulya6922
28.11.2022 19:46

=ЕСЛИ(A1>B1;ЗАМЕНИТЬ(A1;3;3;B1);ЗАМЕНИТЬ(B1;3;3;A1))

Объяснение:

Смотри картинки

Функция ЕСЛИ - позволяет в зависимости от условия выводить два результата. Первый результат возвращается когда, условие истинно, второй результат, когда условие ложно.

ЕСЛИ (условие; первый результат; второй результат)

Здесь сравниваем какое число больше и в зависимости от этого производим замену.

Функция ЗАМЕНИТЬ - позволяет заменить указанное число символов в старой ячейке новыми символами.

ЗАМЕНИТЬ (старая ячейка (в ней заменяем символы, заменяемые символы пропадают); начальная позиция (с какого символа начинаем заменять); число символов (количество заменяемых символов); новые символы (которые вставляем))

Здесь в большем числе убираем 3-5 цифры (т.е. три символа), а вставляем значение меньшего числа.


ИНФОРМАТИКИ, ВЫ ТУТ?!?!? Что здесь нужно сделать я знаю, но вот формулу-нет НАПИШИТЕ ФОРМУЛУ Вот зад
ИНФОРМАТИКИ, ВЫ ТУТ?!?!? Что здесь нужно сделать я знаю, но вот формулу-нет НАПИШИТЕ ФОРМУЛУ Вот зад
0,0(0 оценок)
Ответ:
dulikosha20051
13.05.2023 22:01

program five;

var

 number, quantity: integer;

begin

 quantity := 0;

 read(number);

 while number > 0 do

 begin

   if (number mod 10 mod 5 = 0) then

     inc(quantity);

   number := number div 10;

 end;

 write(quantity);

end.

Объяснение:

program five;  // Название программы

var

 number, quantity: integer;  // Целочисленные переменные:

number - вводимое с клавиатуры число;quantity - количество цифр кратных 5.

begin  // Начало программы

 quantity := 0;  // Количество цифр = 0

 read(number);  // Ввод числа с клавиатуры

 while number > 0 do  // Пока значение переменной number > 0

 begin  // Начало цикла

   if (number mod 10 mod 5 = 0) then  // Если последняя цифра переменной number (number mod 10) при делении на 5 дает остаток 0, тогда

     inc(quantity);  // Прибавляем к переменной quantity единицу

   number := number div 10;  // Удаляем последнюю цифру числа

 end;  // Конец цикла

 write(quantity);  // Вывод ответа

end. // Конец программы

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота