milanagorbovsk
07.02.2022 12:14

Тема Python: 1)Выполните задания по порядку:
1. В третьей строке оформите вывод переменной y с форматного вывода, с количеством знаков в дробной части по умолчанию
2. В четвертой строке оформите вывод переменной y, чтобы выводилось все число в 10 позициях, при этом на дробную часть отводилось 4 знака
3. В пятой строке оформите вывод переменной y, чтобы число выводилось в научном формате с тремя цифрами в дробной части
y = 1/2 + 1/3 + 1/4 + 1/5
2-print(y)
3-print()
4-print()
5-print()
2)Напишите программу, которая вычисляет квадратный корень введенного с клавиатуры числа, с точностью до трех знаков после запятой.
На вход подается вещественное число.
Входные данные:25
Выходные данные:5.000
3)Дано положительное вещественное число X. Выведите его дробную часть:
Входные данные:5.5
Выходные данные:0.5

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Вазген228
05.05.2020 01:59
Алгоритм
1) a x a = a² ⇒ b;    b x a = a³ ⇒ результат
2) a x a = a² ⇒ b;    b x b = a⁴ ⇒ c;   c x c = a⁸ ⇒ c;   c x b = a¹⁰ ⇒ результат

Программа на языке PascalABC.Net
var
  a,b,c,y:real;
begin
  Write('Введите число: '); Read(a);
  b:=a*a; y:=b*a; Writeln('Третья степень числа равна ',y);
  c:=b*b; c:=c*c; y:=b*c;
  Writeln('Десятая степень числа равна ',y)
end.

Тестовые решения:
Введите число: 2
Третья степень числа равна 8
Десятая степень числа равна 1024

Введите число: -13.594
Третья степень числа равна -2512.128188584
Десятая степень числа равна 215512594781.574
0,0(0 оценок)
Ответ:
zhosik1alika
16.05.2021 15:44
1) Как представлено число 8310 в двоичной системе счисления?
В этом вопросе нет ни одного числа двоичного кода. В двоичном коде будет: 10000001110110
2) Дано: , . Какое из чисел С, записанных в двоичной системе счисления, удовлетворяет неравенству ? Я думаю, что вопрос звучал так: Дано: a=222 8 , b=94 Какое из чисел С, записанных в двоичной системе счисления, удовлетворяет неравенству?ответ:2)  С = 250(8сч) удоволетворяет неравенству а=247 меньше С=250 и b= 251 больше С=250.
3) Даны 4 целых числа, записанные в двоичной системе...
ответ: все четыре числа меньше чем 396
4) Укажите через запятую в порядке возрастания все основания систем счисления, в которых запись числа 39 оканчивается на 3.
ответ: 4, 6, 9, 12, 18, 36
5) Запись числа 30 в некоторой системе счисления выглядит так: 110N. Найдите основание системы счисления N.
1)30=1*N^{2}+*N^{1}+*N^{0}
N^{2}+N-30=0
(N+6)(N-5)=0 N\geq=5
2)2B_{16}=2*16+11=43=1*N^{1}+1*N^{0}
N^{2}+N-42=0
(N+7)(N-6)=^{0}N \geq 0 N=6
6) Решить уравнение: где????????????????
7) Сколько единиц в двоичной записи числа 42016 + 22018 – 6?
Я не смог решить
8) Значение арифметического выражения: 274 – 95 + 38 – 25 записали в системе счисления с основанием 3. Сколько цифр «2» содержится в этой записи?
Я не смог решить
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота