Azazel500
08.04.2021 18:38

Составьте блок-схему и напишите программу для вычисления значения функции:
QBasic


Составьте блок-схему и напишите программу для вычисления значения функции:QBasic

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Харли505
06.01.2020 15:28
#include <iostream>
#include <algorithm>
using std::cout;
using std::cin;

int main()
{
int sizeArr, input, min;
cout << "enter size arr: "; //размер массива
cin >> sizeArr;

int arr[sizeArr]; //сам массив
cout << "enter arr: ";
for(int i = 0; i < sizeArr; i++) //заполняем
{
cin >> input;
arr[i] = input;
if(i == 1)
{
min = input;
}
if(arr[i] < min)
{
min = arr[i];
}
}

int size = 0;
for(int i = 0; i < sizeArr; i++)
{
if(min == arr[i])
{
size++;
}
}

cout << std::endl << size;

return 0;
}
0,0(0 оценок)
Ответ:
Дима51497
06.01.2020 15:28
Представим, что мы сняли всю землю с холмов до нулевого уровня в пределах полосы шириной 1 метр, а потом засыпали её обратно так, чтобы уровень стал горизонтальным на высоте h.

Посчитаем объем земли, который был снят.
Всю землю можно разделить на фигуры толщиной 1 метр, в основании которых трапеции с высотой 1 м и основаниями - двумя соседними измерениями высоты. Тогда объем каждой фигуры V(i) = (h(i) + h(i + 1)) / 2, полный объем V = V(1) + V(2) + ... + V(N - 1) = h(1)/2 + (h(2) + h(3) + ... + h(N - 2)) + h(N - 1)/2

Объем земли, который использовался для засыпания, равен V = h (N - 1).

Эти объемы, конечно, равны, тогда h = (h(1)/2 + h(N - 1)/2 + (h(2) + h(3) + ... + h(N - 2))/(N - 1)

PascalABC.NET 3.2.1518:
begin
  var N := ReadInteger;
  print(ReadSeqInteger(N)
           .Select((x, i) -> (i = 0) or (i = N - 1) ? x/2 : x)
           .Sum / (N - 1))
end.

С вводом-выводом в файл:
begin
  var f := OpenRead('INPUT.TXT');
  var N := f.ReadInteger;
  var S := f.ReadInteger / 2;
  for var i := 2 to N - 1 do
    S += f.ReadInteger;
  S += f.ReadInteger / 2;
  print(S / (N - 1))
end.
Железная дорога при строительстве новой железной дороги возникли проблемы. дорога пролегает по холми
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота