Войти
Регистрация
Спроси ai-bota
koshakmarta
20.10.2021 13:13
Написать сообщение на тему исторические сведения о языках программирования Pascal и других языках программирования
Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
sibbb
05.12.2022 12:41
Сколько раз можно написать текст «Узбекистан - независимая страна!» . (Без кавычек) на внешнюю память объемом 1 ГБ...
11111269
13.02.2020 05:19
4. Какое из слов имеет наибольшую сумму кодов символов из таблицы коди- ровки ASCII: ночь, речь, конь?...
nbkmrf
10.05.2023 20:46
, на любом языке программирования ...
Медет111111
27.03.2022 15:44
Даны два числа. Если числа трехзначные, то к каждому числу прибавить 100, если двузначные, то к каждому числу прибавить 10, иначе числа удвоить (умножить на 2). Трехзначное число...
daulbaevazanel123
09.06.2023 22:44
ННаименьшее целое число, большее суммы его цифраименьшее целое число, большее суммы его цифр...
osipovasashaa
10.03.2023 04:32
Вычисление арифметических выражений 1. напишите программу, которая вычисляет с стека значение арифметического выражения, записанного в постфиксной форме. выражение вводится с...
Муликил
25.07.2021 09:47
нужна программа, которая определит по введенным 3 сторонам, существует ли треугольник....
HaskyZ0nG
22.10.2021 13:43
ИНФОРМАТИКА КОД НА ПИТОН Слишком много платьев Имя входного файла: стандартный ввод или stdin Имя выходного файла: стандартный вывод или stdout Ограничение по времени: 2 секунды...
krecet6r
13.10.2021 02:30
Втоматизированный перевод может также включать в себя Базы автофигур. Словари на компакт-дисках, одноязычные или многоязычные. Программы для создания изображений. Программы для...
annamasha2004
21.10.2021 19:47
У исполнителя Бета две команды, которым присвоены номера: 1. прибавь b 2. умножь на 2 (b - неизвестное натуральное число) Выполняя первую из них, Бета увеличивает число на экране...
Ответ:
Rm0
21.10.2020 00:02
Четное число делится на два, а кратное пяти делится на пять, поэтому число должно делиться без остатка на 2х5=10
// PascalABC.NET 3.0,сборка 1076
begin
var n:=ReadInteger('Длина последовательности: ');
var a:=ArrRandom(n,-50,50);
Writeln('Исходная последовательность');
a.Println;
Writeln('Сумма элементов: ',a.Sum);
Write('Кол-во четных, кратных пяти: ');
Writeln(a.Where(x-> x mod 10 = 0).Count)
end.
Тестовое решение:
Длина последовательности: 20
Исходная последовательность
-4 21 -21 -23 14 -39 -12 1 -7 4 17 -45 30 -48 -19 -12 27 -46 -37 15
Сумма элементов: -184
Кол-во четных, кратных пяти: 1
0,0
(0 оценок)
Ответ:
revazhora
21.10.2020 00:02
Четное число делится на два, а кратное пяти делится на пять, поэтому число должно делиться без остатка на 2х5=10
// PascalABC.NET 3.0,сборка 1076
begin
var n:=ReadInteger('Длина последовательности: ');
var a:=ArrRandom(n,-50,50);
Writeln('Исходная последовательность');
a.Println;
Writeln('Сумма элементов: ',a.Sum);
Write('Кол-во четных, кратных пяти: ');
Writeln(a.Where(x-> x mod 10 = 0).Count)
end.
Тестовое решение:
Длина последовательности: 20
Исходная последовательность
-4 21 -21 -23 14 -39 -12 1 -7 4 17 -45 30 -48 -19 -12 27 -46 -37 15
Сумма элементов: -184
Кол-во четных, кратных пяти: 1
0,0
(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота