sophiaukraineoyy0ey
16.01.2020 16:47

Задача "Цифры числа" Напишите программу, определяющую число десятков и единиц в двузначном числе.

Подсказка:

Число единиц – это последняя цифра числа, число десятков – первая цифра. Чтобы получить последнюю цифру любого числа, нужно найти остаток от деления числа на 10. Чтобы найти первую цифру двузначного числа, нужно поделить число нацело на 10.

Задача "Сумма цифр числа"

Напишите программу, в которой рассчитывается сумма цифр двузначного числа.

Задача "Расстояние в метрах"

Напишите программу, которая находит полное число метров по заданному числу сантиметров.

Формат входных данных: на вход программе подаётся натуральное число – количество сантиметров.

Формат выходных данных: программа должна вывести одно число – полное число метров.

Пример 1

Входные данные: 345

Выходные данные: 3

Пример 2

Входные данные: 100

Выходные данные: 1

Пример 3

Входные данные: 89

Выходные данные: 0

Задача "Мандарины"

N школьников делят k мандаринов поровну, неделящийся остаток остается в корзине. Сколько целых мандаринов достанется каждому школьнику? Сколько целых мандаринов останется в корзине?

Формат входных данных: на вход программе подаётся два целых числа: количество школьников и количество мандаринов, каждое на отдельной строке.

Формат выходных данных: программа должна вывести два числа: количество мандаринов, которое достанется школьникам, и количество мандаринов, которое останется в корзине, каждое на отдельной строке.

Пример 1

Входные данные:

3
6

Выходные данные:

2
0

Пример 2

Входные данные:

12
6

Выходные данные:

0
6

Пример 3

Входные данные:

7
4

Выходные данные:

0
4

на уровне 7 класса

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
КираГринРоуз
15.09.2020 02:30

Задача 1:

const N = 15;

const MAX = 15;

const MIN = -15;

var A: array [1..N] of integer;

var i,s1,s2: integer;

begin

randomize();

s1:=0;

s2:=0;

writeln('Исходный массив: ');

for i:=1 to N do

 begin

 A[i]:=random(MAX-MIN+1)+MIN;

 write(A[i],' ');

 if (A[i]<0) then s1:=s1+A[i];

 if (A[i] mod 3 = 0) then s2:=s2+A[i];

 end;

writeln();

writeln('Сумма всех отрицательных элементов: ',s1);

writeln('Сумма всех элементов, кратных 3: ',s2);

end.

Задача 2:

const N = 20;

const MAX = 33;

const MIN = -15;

var A: array [1..N] of integer;

var i,imax,imin: integer;

begin

randomize();

imin:=1;

imax:=1;

writeln('Исходный массив: ');

for i:=1 to N do

 begin

 A[i]:=random(MAX-MIN+1)+MIN;

 write(A[i],' ');

 if (A[i]<A[imin]) then imin:=i;

 if (A[i]>A[imax]) then imax:=i;

 end;

writeln();

writeln('Номер минимального элемента массива: ',imin);

writeln('Номер максимального элемента массива: ',imax);

end.

0,0(0 оценок)
Ответ:
ГНМ
15.09.2020 02:30
program name;
var i,n,x,summa,count:integer;
nechet:boolean;
begin
Writeln('Vvedite n: ');
readln(n);//получаем n
summa:=0;
count:=0;
i:=1;
if(n mod 2 = 1) then nechet := true else nechet := false; //проверяем четное число или нет
while i<n do begin//пока число меньше n
if(nechet) then//если число нечентное
begin
summa:=summa+i*i*i;//прибавляем к сумме куб этого числа
end
else//если число четное
begin
summa:=summa+i*i;//прибавляем квадрат числа
end;
i:=i+1;//прибавляем число на 1
end;
writeln(' summa: ', summa);//выводим сумму
readln();
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота