katjaherson
26.03.2021 17:36

Написать программу в Паскале. y= 2x/x+3 + 3x/x-5
Если знаменатель равен 0 то ввести нет решения

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
uhanovauliana05
29.01.2020 18:45
// PascalABC.NET 3.3, сборка 1625 от 17.01.2018
// Внимание! Если программа не работает, обновите версию!

type
  tt=record
    x:integer;
    y:real
  end;

procedure Compare(f:file of tt; a:array of integer; var r:string);
begin
  r:='true';
  if f.FileSize<>a.Length then begin
    Writeln('Размер массива не соответствует количеству записей файла');
    r:='false';
    exit
    end;
  f.Seek(0);
  var t:tt;
  for var i:=0 to a.Length-1 do begin
    Read(f,t);
    if t.x<>a[i] then begin
      r:='false';
      exit
      end
    end
end;

begin
  var f:file of tt;
  var n:=ReadInteger('n=');
  Writeln('Введите ',n,' значений для сравнения');
  var a:=ReadArrInteger(n);
  var good:='';
  Assign(f,'f1.dat'); Reset(f);
  Compare(f,a,good);
  Writeln(good);
  f.Close
end.

Внимание! Поскольку входной файл не был представлен, программа не тестировалась! Проверена лишь компиляция программы.
0,0(0 оценок)
Ответ:
DanilДюжик
17.12.2022 11:05
// Программа и скриншот ее работы в приложениях.

const
    T_max=10;

var  
    i:byte;
    T:array[1..T_max]of integer;
   
begin
  writeln('Заполнение массива из ', T_max ,' элементов случайными данными');
 
  //начальные значения min и max
  for i:=1 to T_max do begin
    T[i]:=random(-79,79);// диапазон случайных чисел
    write(T[i]:6);
   
    if (T[i]<0) then
      T[i]:=0
    else if (T[i]>0) then
      T[i]:=1;
  end;

  writeln(); 
  writeln();
  writeln('Положительные элементы заменить единицами,отрицательные нулями ');
  writeln('Результат'); 
  for i:=1 to T_max do
    write(T[i]:6);
 
 end.

Задан массив целых чисел изт10 элементов. положительные элементы заменить единицами,отрицательные ну
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота