Thevalk3
09.07.2020 20:34

Составить программу которая умножает введенное число на 5 если оно меньше 100 или умножают на 4 если введенное число не меньше 10 и выводит результат на экран

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
darina20034
23.03.2023 02:37

Программа на Python:

for base in range(2, 15):

   """ Вводимые данные """

   x = 511

   s = ""

   flag = True

   """ Перевод числа из 10 в base """

   while x:

       s += str(x % base)

       x //= base

   # На выводе обратный порядок переведённого числа, однако нам и не важно это

   """ Проверка кол-ва несовпадающих элементов """

   for el in s:

       if s.count(el) != 1:

           flag = False

   """ Вывод и остановка цикла"""

   if flag:

       print(f"{s} (base: {base})")

       break

0,0(0 оценок)
Ответ:
влад1922
25.01.2022 10:03

1)
number = list(input())

if int(number[0])%2==0 and int(number[1])%2==0 and int(number[2])%2==0:

 print('Да')

else:

 print('Нет')
2)

number = list(input())

if((int(number[0])*int(number[1])*int(number[2])) % 2 == 0):

 print('Нет')

else:

 print('Да')

Объяснение:

1) Получаем вводимое число и разбиваем строку на массив.
Проверяем каждую цифру на чётность, в случае когда все они чётные - выводим "Да", а в других случаях "Нет".
2) Получаем вводимое число и разбиваем строку на массив.
Умножаем все цифры друг на друга и проверяем произведение на чётность, если оно чётное выводим "Нет", а в других случаях "Да"

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота