naastul2
18.01.2023 20:52

написать программу, которая запрашивает числа до тех пор,пока не будет введен 0. Язык Паскаль. (Можно всю задачу? Условие, тел цикла и т.д.)

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
dmmkuplinov
13.05.2023 21:10
// здесь кусок кода, в котором считываем введённый месяц в переменную
//month
char getTime(int month)
switch (month){
case '1' : return 'winter'; break;
case '2' : return 'winter'; break;
case '12' : return 'winter'; break;
case '3' : return 'spring'; break;
case '4' : return 'spring'; break;
case '5' : return 'spring'; break;
case '6' : return 'summer'; break;
case '7' : return 'summer'; break;
case '8' : return 'summer'; break;
case '9' : return 'autumn'; break;
case '10' : return 'autumn'; break;
case '11' : return 'autumn'; break;
default : 'NO'; break;
}
printf(getTime(month));
0,0(0 оценок)
Ответ:
rostislav2017
17.07.2021 23:53
1)var
n:longint;
begin
readln(n);
if n mod 5=0 then writeln('Число N является кратным чилслу 5')else
writeln('Чило N не является кратным числу 5' );
end.
2)
var
a,b,c:longint:
begin
readln(a,b,c);
if (a+b)div 2=c then writeln('Число C является средним арефметическим чисел A и B') else writeln(' Число C является средним арефметическим чисел A и B') else writeln('Число C не является средним арефметическим чисел A и B ');
end.
3)
var
a:longint;
begin
write('Сколько вам лет?');
readln(a);
if a<14 then write('Вам еще рано получать паспорт?') else write('Поздравляю! Вы гражданин России!');
end.
4)
var
a:extended;
begin
readln(a);
if (a>36)and(a<37) then writeln('Вы здоровы') else writeln('Вы больны');
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота