artemmavericksmesrri
24.08.2020 01:42

Написать программу для удаления из нее повторяющиеся символов и все пробел

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
tutuginovvan
06.02.2020 10:57

Аналоговый сигнал — сигнал данных, у которого каждый из представляющих параметров описывается функцией времени и непрерывным множеством возможных значений. различают два пространства сигналов — пространство L (непрерывные сигналы), и пространство l (L малое) — пространство последовательностей.

Протсранство l (L малое) есть пространство коэффициентов Фурье (счётного набора чисел, определяющих непрерывную функцию на конечном интервале области определения), пространство L — есть пространство непрерывных по области определения (аналоговых) сигналов.

При некоторых условиях, пространство L однозначно отображается в пространство l (например, первые две теоремы дискретизации Котельникова).

Аналоговые сигналы описываются непрерывными функциями времени, поэтому аналоговый сигнал иногда называют континуальным сигналом. Аналоговым сигналам противопоставляются дискретные (квантованные, цифровые). Примеры непрерывных пространств и соответствующих физических величин:

прямая: электрическое напряжение

окружность: положение ротора, колеса, шестерни, стрелки аналоговых часов, или фаза несущего сигнала

отрезок: положение поршня, рычага управления, жидкостного термометра или электрический сигнал, ограниченный по амплитуде

различные многомерные пространства: цвет, квадратурно-модулированный сигнал.

0,0(0 оценок)
Ответ:
shaihiev
11.04.2021 11:14
В последней задаче понадобятся переводные коэффициенты.
1 берковец=10 пудов=400 фунтов=38400 золотников.
Отсюда:
1 фунт = 38400/400 = 96 золотников
1 пуд = 400/10 = 40 фунтов
1 берковец = 10 пудов

№1

var
  n:integer;
 
begin
  Write('Введите двухзначное число: '); Read(n);
  n:=Abs(n); { убираем минус, если он есть }
  Writeln('Среднее арифметическое цифр числа: ',
    (n div 10 + n mod 10)/2)
end.

Пример
Введите двухзначное число: 43
Среднее арифметическое цифр числа: 3.5

№2

var
  n:integer;
 
begin
  Write('Введите двухзначное число: '); Read(n);
  n:=Abs(n); { убираем минус, если он есть }
  Writeln('Разность количества десятков и единиц равна ',n div 10 - n mod 10)
end.

Пример
Введите двухзначное число: 38
Разность количества десятков и единиц равна -5

№3

var
  a:real;
 
begin
  Write('Площадь, ар: '); Read(a);
  Writeln('Полных кв.км: ',Trunc(a/10000))
end.

Пример
Площадь, ар: 252123234
Полных кв.км: 25212

№4

const
  f=96; { фунт }
  p=40; { пуд }
  b=10; { берковец }

var
  z:longint;
  kb,kp,kf:integer;
 
begin
  Write('Введите вес в золотниках: '); Read(z);
  kf:=z div 96;
  z:=z mod 96;
  kp:=kf div 40;
  kf:=kf mod 40;
  kb:=kp div 10;
  kp:=kp mod 10;
  Writeln('Это составит ',kb,' берковцев, ',kp,' пудов, ',
      kf,' фунтов, ',z,' золотников')
end.

Пример
Введите вес в золотниках: 374252
Это составит 9 берковцев, 7 пудов, 18 фунтов, 44 золотников
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота