Kotmi679
08.04.2021 07:48

Вопросы и задания 3 1. Определите, что выведет этот фрагмент программы для списка на Рис. 1:
m = A[-1]
for i in range(4) :
if A[i] < m :
m = A[i]
print(m)
2. Напишите программу, которая заполняет список из 20 элементов случайными
целыми числами на отрезке [50; 150] и находит в нём минимальный и
максимальный элементы и их номера.


Вопросы и задания 3 1. Определите, что выведет этот фрагмент программы для списка на Рис. 1: m = A[-

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
emotuz60p011ls
05.06.2022 03:19

a = int(input())

if a == 1:

   print ("Год")

elif 2<= a and a<=4:

   print ("Года")

elif 5<=a and a<=20:

   print ("Лет")

elif a==31:

   print ("Год")

elif 32<= a and a<=34:

   print ("Года")

elif 35<=a and a<=40:

   print ("Лет")

elif a==41:

   print ("Год")

elif 42<= a and a<=44:

   print ("Года")

elif 45<=a and a<=50:

   print ("Лет")

elif a==51:

   print ("Год")

elif 52<= a and a<=54:

   print ("Года")

elif 55<=a and a<=60:

   print ("Лет")

elif a==61:

   print ("Год")

elif 62<= a and a<=64:

   print ("Года")

elif 65<=a and a<=70:

   print ("Лет")

elif a==71:

   print ("Год")

elif 72<= a and a<=74:

   print ("Года")

elif 75<=a and a<=80:

   print ("Лет")

elif a==81:

   print ("Год")

elif 82<= a and a<=84:

   print ("Года")

elif 85<=a and a<=90:

   print ("Лет")

elif a==91:

   print ("Год")

elif 92<= a and a<=94:

   print ("Года")

elif 95<=a and a<=100:

   print ("Лет")

elif a==101:

   print ("Год")

elif 102<= a and a<=104:

   print ("Года")

elif 105<=a and a<=120:

   print ("Лет")

else:

   print ("Число не подходит")

0,0(0 оценок)
Ответ:
Ksyusha891
04.12.2021 02:51

Насчет "Назови математические функции, содержащие в модуле math.", они все математические, сам за себя модуль говорит, но привиду, те, которые я буду сейчас использовать...

Код, который округляет числа, это math.ceil и math.floor

#Создаем переменную в которую будем вводить числа, пусть будет Называться "у", я буду использовать float, потому что мне так нравится.

import math

y = float(input("Введи число: ")

print("Округление до ближайшего большого числа: ", math.ceil(y))

print("Округление вниз: ", math.floor(y))

#Вот обычный код с использованием "Math"

#Создадим программу которая будет вычислять квадратный корень чисел, команда - math.sqrt, также создаем переменную, теперь пусть будет "b"

import math

b = float(input"Enter number: ")

print(b, math.sqrt(b))

#Вот код который вычисляет корень квадрата числа...

Можно создать большой пример с дробями,cтепенями, квадратным корнем, и ответ которого, можно округлить, например:

import math

a = 10

b = 15

print("ответ, округленный: ", math.ceil(math.sqrt(a**4 + b)/(a**2 + b **2)))

Прибавим любое число к числу Пи

команда - math.pi

import math

print("Число Пи это: " + str(math.pi))

a = float(input("Введи число: "))

print("ответ: ", a + math.pi))

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота