11. Напишите программу, которая в последовательности целых чисел определяет сумму двух наибольших и сумму двух наименьших. Программа должна вывести две этих
суммы в указанном порядке. Программа получает на вход целые числа, количество
введённых чисел не известно, последовательность чисел заканчивается числом 0 (0
— признак окончания ввода, не входит в последовательность). Количество чисел не
превышает 1000. Введённые числа по модулю не превышают 30 000.
В последовательности не менее двух чисел.
12. Напишите программу для решения следующей задачи. Камера наблюдения
регистрирует в автоматическом режиме скорость проезжающих мимо неё
автомобилей, округляя значения скорости до целых чисел. Необходимо определить
максимальную зарегистрированную скорость автомобиля. Если скорость хотя бы
одного автомобиля была меньше 30 км/ч, выведите «YES», иначе выведите «N0».
Программа получает на вход число проехавших автомобилей N (1 < N < 30), затем
указываются их скорости. Значение скорости не может быть меньше 1 и больше
300.Программа должна сначала вывести максимальную скорость, затем YES или NO. НА ПАСКАЛЕ
function summdel(x:integer):integer; //результат - сумма делителей х var k,sum:integer; begin sum:=0; for k := 1 to x div 2 + 1 do if x mod k = 0 then sum:= sum+k; summdel:=sum; end;
begin writeln('Введите границы a,b '); readln(a,b); maxsumm := 1; max := 1; for i := a to b do begin if summdel(i) > maxsumm then begin maxsumm:= summdel(i); max := i; end; end; writeLn('Максимальная сумма делителей - ', maxsumm, ' число - ',max) end.
Для всех заданий воспользуемся формулой N=2^i? где N -количество цветов, а i -количество бит на 1 пиксель. Задача 1. N=2^4=16 цветов.
Задача 2. N=224=2^i, поскольку для кодирования 128 цветов необходимо 7 бит, а для кодирования 256 цветов -8 бит, выбираем большее число, то есть 8 бит или 1 байт.
Задача 3. 65536 это 2^16⇒требуется 16 бит или 2 байта.
Задача 4. 1. Узнаем общее количество пикселей 1280*1024=1310720 2. Полученное число умножаем на глубину цвета 1310720*32=41943040 бит = 41943040/8 = 5242880 байт = 5242880/1024 = 5120 кб =5120/1024 = 5 Мб ответ: 5 Мб
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку