Nastia2k
31.07.2022 15:25

3. Точка А задана координатами X,Y. Написать программу, которая выводит слово «Принадлежит», если точка принадлежит
заштрихованной области
и «не принадлежит» в противном случае протестировать
программу для
точек (0,0), (2,2),
(0.5,0.5), (0.5,-1.5), (-0.5,0.5), (-2,-1), (-1,-2), (-1, 1), (2, 0).


3. Точка А задана координатами X,Y. Написать программу, которая выводит слово «Принадлежит», если то

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
ФилиситиФорНау
27.01.2021 18:08

program chik;

var x,y:real;

begin

readln(x,y);

if((y<=2)and(x>=-3)and(x<=2)and(y>=0))or

((y<=0)and(x>=-1)and(x<=1)and(y>=-1)and(x*x+y*y<=1))then

writeln('ПРИНАДЛЕЖИТ')else writeln('Не принадлежит');

end.

Объяснение:

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота