shoma22
10.02.2021 13:26

Составить программу для вычисления суммы бесконечного ряда с использованием оператора цикла Язык - Pascal


Составить программу для вычисления суммы бесконечного ряда с использованием оператора цикла Язык - P

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Мейвис00
12.02.2021 22:27

var

 k,h:integer;

 p,s,x,eps,n,p1:real;

begin

 x:=10;

 while (x<0) or (1<x) do begin   {Условие ввода 0>x>1}

   write('Введите X = '); readln(x);

   end;

 eps:=1e-@;   //В место @ нужно ввести погрешность в положительном числовом виде (вычислить до @-го знака после запятой)

 p:=x;

 n:=2;

 p1:=1;

 h:=1;

 while abs(p)>eps do   {Условие выхода: очередной член ряда по модулю меньше eps}

 begin

   writeln('[Отладка]  ',eps,'    ',p,'    ',s,'    ',n);   //отладка

   for var i:=0 to 1 do begin

     k:=k+1;

     p1:=p1*k;

   end;

   h:=h*-1;

   p:=h*(power(2*x,n))/p1;   {Вычисление очередного члена ряда}

   s:=s+p;

   n:=n+2;

 end;

 writeln('cos(2x-1) = ', s);

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота