aluanakim
22.08.2021 06:43

Составить программу для учета и обработки данных о наличии на складе автомашин, Тас нужно вывести на экран информацию о модели и года выпуска автомашин, цена которых меньше, чем 3000 усл. Ед Пусть запись содержит следующие поля: модель (marka), год выпуска (year) и цена автомобиля (price), а сами записи (в количестве хранятся в массиве а1

​


Составить программу для учета и обработки данных о наличии на складе автомашин, Тас нужно вывести на

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
lera5471
24.06.2021 07:46
Var  
a, b: array[1..10] of integer;  
i, min, max, sum: integer;  
begin  
min := 10;  
for i := 1 to 10 do   begin    
write('Введите ',i,'-ый элемент первого массива ');
Readln(a[i]);    
write('Введите ',i,'-ый элемент второго массива ');
Readln(b[i]);  
if a[i] < min then min := a[i];    
if b[i] > max then max := b[i];  
end;  
for i := 1 to 10 do    
write(a[i], ' ');  
Writeln;  
for i := 1 to 10 do    
write(b[i], ' ');  
writeln;   
writeln('Минимальное первого массива ', min);   writeln('Максимальное первого массива ', max);  
sum := min + max;  
for i := 1 to 10 do    
if (i mod 2) = 0 then      
a[i] := sum else
b[i] := sum;  
for i := 1 to 10 do    
write(a[i], ' ');  
Writeln;  
for i := 1 to 10 do    
write(b[i], ' ');
end.
0,0(0 оценок)
Ответ:
stovhelen
07.06.2022 15:14
Тип данных      Длина      Диапазон значений
                           байт
                     ЦЕЛЫЕ ТИПЫ
integer                   2            -32768...32767
byte                       1            0...255
word                      2            0...65535
shortint                  1            -128...127
longint                    4            -2147483648...2147483647
            ВЕЩЕСТВЕННЫЕ ТИПЫ
real                        6             2,9 * 10^-39 ... 1,7 * 10^38
single                    4              1,5*10^-45 ... 3,4*10^38
double                   8              5*10^-324 ... 1,7*10^308
extended               10            3,4*10^-4932 ... 1,1*10^4932
                ЛОГИЧЕСКИЙ ТИП
boolean                 1               true,    false
                СИМВОЛЬНЫЙ ТИП
char                      1               все символы из таблицы ASCII
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота