succura
29.09.2021 11:42

Паскаль ,через
С Клавиатуры вводиться Границы промежутка - 2 числа (от 1 до
20). Написать программу, которая найдет сумму и произведение всех
целых чисел промежутка включительно и вывода результат на
экран
program 1;
var
i, dobutok, suma :integer;
begin
dobutok:=1;
suma:=0;
for i:=1 to 20 do
begin
dobutok:=dobutok*i;
suma:=suma+i;
end;
write('dobutok = ',dobutok, ' , suma = ',suma);
end.
Как сделать чтоб в этой программе границы вводились С КЛАВИАТУРЫ?

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
shopniceLol
08.10.2022 18:13

#include <iostream>

#include <cmath>

#include <algorithm>

#pragma GCC optimize("Ofast")

#define ll long long

#define ld long double

using namespace std;

ll digits(ll a){

   ll c = 0;

   while(a > 0){

       a /= 10;

       c++;

   }

   return c;

}

signed main() {

   srand(time(NULL));

   const ll n = 25;

   ll sum = 0;

   ll mas[n];

   for(ll i = 0; i < n; i++){

       mas[i] = rand() % 493 - 246;

       cout << mas[i] << " ";

       if(digits(mas[i]) == 2 && mas[i] % 4 == 0)

           sum += mas[i];

   }

   cout << "\n" << sum;

}

0,0(0 оценок)
Ответ:
rudnevskaya20041
08.10.2022 18:13

1.Найти сумму чётных цифр числа.

uses crt;
var a,x:integer;
i,s:integer;
begin
clrscr;
writeln('Vvedite chislo');
readln( a ); x:=a;
s:=0;
while ( x<>0 ) do
begin
if x mod 2 =0 then s:= s + (x mod 10);
x:= x div 10;
end;
writeln( 'Summa= ', s );
readln;
end.

 

2.Вывести на экран таблицу умножения.

uses crt;
var a: array [1..10,1..10] of integer;
i,j:integer;
begin
clrscr;
for i:=2 to 10 do
begin
writeln;
for j:=1 to 10 do
write(i*j,'  ');
end;
writeln;
readln;
end.

 

3.Найти все двухзначные числа, сумма которых равна а.

uses crt;
var a,x,i,s:integer;
begin
clrscr;
writeln('Vvedite a');
readln(a);
for i:=10 to 99 do
begin
x:=i;
s:=0;
while (x<>0) do
begin
s:=s+(x mod 10);
x:=x div 10;
end;
if s=a then write(i,' ');
end;
readln;
end.

 

4.Найти количество и сумму чётных делителей.

uses crt;
var s,k,i,a:integer;
begin
clrscr;
writeln('Vvedite chislo');
readln(a);
i:=2;
s:=0;
k:=0;
while i<>a do
begin
if (a mod i =0) and (i mod 2=0) then
begin
s:=s+i;
k:=k+1;
end;
i:=i+1;
end;
writeln('Summa chisletelei =',s);
writeln('Kolichestvo delitelei= ',k);
readln;
end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота