kseniaflrsova72
27.04.2022 08:48

Напишите программу для решения следующей задачи. Камера наблюдения регистрирует в автоматическом режиме скорость проезжающих мимо неё автомобилей, округляя значения скорости до целых чисел. Необходимо определить максимальную зарегистрированную скорость автомобиля. Если скорость хотя бы одного автомобиля была меньше 30 км\ч, выведите YES, иначе выведите NO. Программа получает на вход число проехавших автомобилей N (1=
Программа должна сначала вывести максимальную скорость, затем YES или NO.

Написать нужно на Python.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
WepaDarkSouls
15.01.2021 19:10

L = "NO"

max_v = 0

N = int(input())

for i in range(N):

   x = float(input())

   if int(x) < 30:

       L = "YES"

   if int(x) > max_v:

       max_v = int(x)

print("Максимальная скорость:",max_v)

print(L)

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота