ЁшкинКот2479
05.09.2020 18:29

Дан массив из 10 чисел, найти нули и подсчитать их количество 9 класс, информатика. Нарисовать блок схему, составить програму​

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
bockovickof
09.04.2021 19:02

1)

var

  s : real;

  i, n : integer;

begin

  s := 0;

  read (n);

  for i := 1 to n do s := s + 1 / i;

  writeln (s);

end.

 

2)

var

  a, i : integer;

begin

  a := 1;

  for i := 1 to 8 do

  begin

    a := a * 2;

    writeln ('Через ', i * 3, 'часов будет ', a, ' амеб');

  end;

end.

 

3)

var

  n, i : integer;

  x, s : real;

begin

  s := 0;

  read (n, x);

  for i := 1 to n do

    s := s + sin (i * x);

  writeln (s);

end.

 

4)

var

  n, a, r, i : integer;

begin

  r := 1;

  read (a, n);

  for i := 1 to n do r := r * a;

  writeln (r);

end.

0,0(0 оценок)
Ответ:
Recor23
15.06.2022 05:21

Вот:

Объяснение:

1. Задание

В соответствии с вариантом разработайте алгоритм обработки элементов массива.

Напишите программу на алгоритмическом языке в соответствии со схемой алгоритма.

Проведите тестирование программы в среде программирования.

Вариант №3

Массив Х [36] целых элементов задать датчиком случайных чисел.

Переписать подряд в массив Y положительные элементы массива Х. Определить, сколько в массиве Y четных элементов.

Контрольные вопросы

1. Какие ограничения накладываются на индексы элементов массивов?

описания массивов на языке Си. Понятия размерности массива, описание размерности массивов.

3. Задание типов элементов массива. Могут ли элементы массива иметь разный тип?

4. Как располагаются элементы массива в памяти?

5. Чем отличаются алгоритмы поиска максимального и минимального элемента массива.

6. Чем отличаются алгоритмы расчета суммы и подсчета числа элементов массива.

Файл программы также в архиве

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота