AdinaKhamzina1
10.06.2021 11:41

нужно написать на паскале: 1. Написать программу, которая в массиве из N двухзначных положительных чисел (числа могут повторяться), находит сумму и количество тех из них, которые делятся на введенное число C (при вводе значения числа С просим вводить число не более 100. Проверять этот факт не надо). Если же таковых чисел нет, то требуется вывести об этом информацию на экран.

2. Петр Макарович работает водителем маршрутки. Каждый день в течении А дней, он заправляет свою "Газель" до полного (полный бак) на автозаправки Ёжик-Нефть. Каждый день цена за литр бензина может быть разная и зависит только от фантазии владельцев данной автозаправки. Требуется определить, максимальную и минимальную сумму наличности, которая понадобится Петру Макаровичу для заправки своей "Газели" в течении указанного времени, при условии, что бак автомобиля НЕ меняет свой объем и составляет В литров.

3. Бывший бухгалтер Мария Ивановна ведет скурпулезный подсчет того количества денег, которое она тратит ежемесячно на содержание своего кота Василия уже Х лет подряд(количество лет число целое). Рацион кота из месяца в месяц не меняется. Стоимость ежемесячной корзины "на Кота" она регулярно записывает. Требуется расположить траты Марии Ивановны по возрастанию, а также определить разность между первой и последней тратами. (без поиска минимума и максимума)

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
misscalina1950
04.06.2021 03:44

відповідь:

решение логических выражений принято записывать в виде таблиц истинности – таблиц, в которых по действиям показано, какие значения принимает логическое выражение при всех возможных наборах его переменных.

при составлении таблицы истинности для логического выражения необходимо учитывать порядок выполнения логических операций, а именно:

действия в скобках,

инверсия (отрицание),

& (конъюнкция),

v (дизъюнкция),

=> (импликация),

< => (эквивалентность).

алгоритм составления таблицы истинности:

  1. выяснить количество строк в таблице (вычисляется как 2n, где n – количество переменных + строка заголовков столбцов).

  2. выяснить количество столбцов (вычисляется как количество переменных + количество логических операций).

  3. установить последовательность выполнения логических операций.

  4. построить таблицу, указывая названия столбцов и возможные наборы значений исходных логических переменных.

  5. заполнить таблицу истинности по столбцам.

  6. записать ответ.

 

пример 6

построим таблицу истинности для выражения f=(avb)& (¬av¬b).

1. количество строк=22 (2 переменных+строка заголовков столбцов)=5.

2. количество столбцов=2 логические переменные (а, в)+ 5 логических операций (v,& ,¬,v,¬) = 7.

0,0(0 оценок)
Ответ:
katerinkakotoysmyf
31.08.2022 15:54
// PascalABC.NET 3.1, сборка 1172 от 19.02.2016
begin
  var s:=Range(1,ReadInteger('n='),2).Select(x->Rec(x,x*x,x*x*x));
  foreach var e in s do
    Writeln(e.Item1:10,e.Item2:10,e.Item3:10)
end.

Тестовое решение:
n= 20
         1         1         1
         3         9        27
         5        25       125
         7        49       343
         9        81       729
        11       121      1331
        13       169      2197
        15       225      3375
        17       289      4913
        19       361      6859
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота