хочуха04
17.12.2022 06:15

Изобретением данного уПриведите общую характеристику языка Паскаль. Какова структура программы на Паскале? Задание 2 .

Составить блок-схему алгоритма и программу на Паскале для вычисления функций z. Ввести программу в Паскале, вычислить значения функции и проверить ее для самостоятельно выбранных трех пар значений переменных X и Y.
28.png

Задание 3 .

Составить блок-схему алгоритма и программу для обработки массива из 20 чисел X=(0,3;5;68;-3;32;-80;-9;-26;-9;40;36;13;15;28;-0,7;-36;-0,3;8;15;-7) при b=5. Вычислить произведение и количество элементов, не равных нулю и меньших b.

Задание 4 .

Составить программу и блок-схему для вычисления суммы площадей всех квадратов, стороны которых изменяются в цикле от 1 до 10. В отчет включить тексты программ на Паскале, результаты работы в виде скриншотов окна программы с отображением кодов и результатов работы.
чёного является

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
maliiii02
25.06.2021 09:05
#include <iostream>
#include <ctime>
#include <stdlib.h>
using namespace std;

double Sum(int *A, int N, int C, int M);

int main()
{
    srand(time(0));
    int N, C = 19, M = 30;
    cout << "N = ", cin >> N;
    int Train[N];
    for(int i = 0; i < N; i++)
        cout << (Train[i] = rand() % (M+1)) << " ";
    cout << "\nSum = " << Sum(&Train[0], N, C, M);;
    return 0;
}

double Sum(int*A, int N, int C, int M)
{
    double S = 0;
    int k = 0;
    for(int i = 0; i < N; i++)
    {
        S += A[i]*C;
        k +=M - A[i];
    }
    cout << "\nk = " << k;
    return S;
}
0,0(0 оценок)
Ответ:
Алмат1335
25.06.2021 09:05
#include <iostream>
#include <ctime>
#include <stdlib.h>
using namespace std;

double Sum(int *A, int N, int C, int M);

int main()
{
    srand(time(0));
    int N, C = 19, M = 30;
    cout << "N = ", cin >> N;
    int Train[N];
    for(int i = 0; i < N; i++)
        cout << (Train[i] = rand() % (M+1)) << " ";
    cout << "\nSum = " << Sum(&Train[0], N, C, M);;
    return 0;
}

double Sum(int*A, int N, int C, int M)
{
    double S = 0;
    int k = 0;
    for(int i = 0; i < N; i++)
    {
        S += A[i]*C;
        k +=M - A[i];
    }
    cout << "\nk = " << k;
    return S;
}
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота