elizavetachery
23.07.2022 02:26

Написать программу, которая запрашивает дату рождения (день и месяц) и сообщает соответствующий знак зодиака на языке C++​

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
nastusa098
30.12.2021 19:39

var

  s : string;

  i : integer;

  f : boolean;

begin

  readln (s);

  writeln ('Тут ', length (s), ' символов');

  f := true;  

for i := 1 to length (s) div 2 do

    if s[i] <> s[length (s) - i + 1] then f := false;

  writeln ('Это слово является перевертышем: ', f); //True/False

end.

 

var

  s : string;

  i, k, count : integer;

  c : char;

begin

  readln (s);

  count := 0;

  for i := 1 to length (s) do

    if s[i] <> ' ' then

    begin

       c := s[i];

       k := i + 1;

       break;

    end;

  for i := k to length (s) do

    if (s[i] = ' ') and (c <> ' ') then

    begin

       if s[i - 1] = c then inc (count);

       c := ' ';

    end

    else if c = ' ' then c := s[i];

  if (c <> ' ' ) and (s[length (s)] <> ' ') and (c = s[length (s)]) then inc (count);

  writeln (count);

end.

0,0(0 оценок)
Ответ:
xalyva
02.06.2023 20:36

таблица - Рейсы

ид

название

ид начального пункта

ид конечного пункта

 

таблица - пункты (остановки)

ид

название

 

таблица - растояние+рейс

ид пункта1

ид пункта2

растояние (растояние между пунктами 1 и 2, пункты должны быть только соседними)

ид рейса

цена (стоимость проезда между пунктами 1 и 2)

 

таблица - автобусы

ид

потребление топлива (на 1 км)

кол-во посадочных мест

 

таблица - рейс+автобус (какие автобусы по каким рейсам ездят)

ид рейса

ид автобуса

 

таблица - билеты

ид рейс

дата-время

кол-во проданных билетов

 

таблица - сотрудники

ид

имя

должность

ставка

телефон

 

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота