sasha2442
20.09.2021 19:23

Написать программу с цикла for вычисление факториала числа 29, нахождение суммы ряда s=1+1/2+1/3+...+1/n​

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
86669
21.11.2022 18:02

 

Любой из нас с самого детства знает, что красный сигнал светофора запрещает движение, зелёный сигнал разрешает движение, а жёлтый - предупреждает о смене сигналов.

Но далеко не каждый знает, как работает современный «продвинутый» транспортный светофор.

 

К красному сигналу добавился жёлтый. Через пару секунд они оба одновременно погаснут, и включится зелёный.

 
 

Красный с жёлтым погасли, включился зелёный, и можно двигаться во всех направлениях (если, конечно, знаками или разметкой не дано иных указаний).

Но не торопитесь начинать движение. Сколько бед и трагедий видел автор этих строк, когда соседи по дороге слепо ориентировались на зелёный сигнал. Сначала нужно убедиться, остановились ли те, кому сейчас загорелся красный. Кто-то может просто не успеть остановиться, а кто-то ну очень спешит и готов проскочить перекрёсток, пусть даже, рискуя жизнью (ладно бы только своей, но ведь и чужой тоже).


Расскажи, как работает светофор. какие знаки или сигналы при этом используются? сколько их?
Расскажи, как работает светофор. какие знаки или сигналы при этом используются? сколько их?
Расскажи, как работает светофор. какие знаки или сигналы при этом используются? сколько их?
0,0(0 оценок)
Ответ:
gsubxdu
20.05.2021 15:09
Задача 1

const max_size = 100;

var a: array[1..max_size] of real;

 i, n: integer;

 f: boolean;

begin

 read(n); {Во всех задачах считаю, что n <= max_size}

 for i := 1 to n do

   read(a[i]);

 f := true;

 for i := 2 to n do

   f := f and (a[i] > a[i - 1]);

 write(f)

end.

Пример ввода:

4

1 2 3 4

Пример вывода:

TRUE

Задача 2

const max_size = 100;

var a: array[1..max_size] of real;

 i, n, imax, imin: integer;

 temp: real;

begin

 read(n);

 for i := 1 to n do

   read(a[i]);

 imax := 1;

 imin := n;

 for i := 2 to n do

   if a[i] > a[imax] then

     imax := i;

 for i := n - 1 downto 1 do

   if a[i] < a[imin] then

     imin := i;

 temp := a[imax];

 a[imax] := a[imin];

 a[imin] := temp;

 for i := 1 to n do

   write(a[i], ' ');

end.

Пример ввода:

4

1 2 3 4

Пример вывода:

4 2 3 1

Задача 3

const max_size = 100;

var x: array[1..max_size] of integer;

 i, n, temp: integer;

begin

 read(n);

 for i := 1 to n do

   read(x[i]);

 for i := 1 to n div 2 do

 begin

   temp := x[i];

   x[i] := x[n - i + 1];

   x[n - i + 1] := temp;

 end;

 for i := 1 to n do

   write(x[i], ' ');

end.

Пример ввода:

4

1 2 3 4

Пример вывода:

4 3 2 1

Задача 4

const max_size = 100;

var x: array[1..max_size] of integer;

 i, n, sum: integer;

begin

 read(n);

 for i := 1 to n do

   read(x[i]);

 for i := 1 to n do

   if i = x[i] then

     sum := sum + x[i];

 write(sum)

end.

Пример ввода:

4

1 2 3 4

Пример вывода:

10

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота