niceglotatel
26.04.2023 22:40

На vba: дано число. составить программу, которая определяет. входит ли в него цифра 3.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
yannappp1
15.06.2020 21:50

Дам 2 кода на с++ и на паскаль, попробуешь перевести на VBA . не сложно.

с++

int a,b,count(0);;
cin>>a;
while(a>0)
{
b=a%10;
if (b==3) count++;
a/=10;
}
if (count > 0) cout<<"OK";
else cout<<"NO";

 

pascal как то так

uses crt;

var a,b,count:integer;
begin
readln(a);
count:=0;

while a > 0 do
begin
b:=a mod 10;
if b = 3then inc(count);
a:=a div 10;
end;
if count > 0 then writeln('ok')
else
writeln('NO');
readln;
end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота