lysiya1
25.09.2020 10:42

Составить программу вычисления суммы кубов чисел кратных 5, на промежутке от 15 до 50. (паскаль) От

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
pasagilazutdino
01.02.2021 20:20

//PascalABC.NET 3.7.2

##

Range(15, 50).Where(x -> x mod 5 = 0).Select(x -> x * x).Sum().Println();

0,0(0 оценок)
Ответ:
Призванный
01.02.2021 20:20

Составим программу вычисления суммы ряда чисел 5, 10, 15, …, 50 на языке программирования Pascal ABC. Введем обозначения следующих величин: пусть s – сумма чисел ряда, которую надо найти, а i – порядковый номер чисел ряда. Начальное значение суммы s будет равным нулю. Так как чисел несколько, то будем использовать в программе оператор цикла с параметром for. По условию задачи числа суммируются, начиная с числа 5, с интервалом 4 числа, поэтому значение i в каждом цикле будем увеличивать на 4.

Программа может выглядеть так:

program zadacha;

uses crt;

var s,i: integer;

begin

s:=0; {Задание начального значение суммы s}

for i:=5 to 50 do begin

s:=s+i; {Вычисление суммы чисел}

i:=i+4; {Увеличение значения параметра i на 4}

end;

writeln ('s=',s) {Вывод результата суммы s}

end.

Можно решить данную задачу и вторым используя операцию mod:

program zadacha;

uses crt;

var s,i: integer;

begin

s:=0; {Задание начального значение суммы s}

for i:=5 to 50 do

if i mod 5=0 {Поиск чисел, кратных 5}

then s:=s+i; {Вычисление суммы чисел}

writeln ('s=',s); {Вывод результата суммы s}

end.

ответом будет s=275.

Составить программу нахождения значения функции у= 5х+х2, при х=50, 49, 48, 47, …, 40.

program zadacha;

uses crt;

var x,y,i:integer;

begin

for i:=50 downto 40 do begin y:=5*i+i*2; writeln ('y=',y); end;

writeln ('y=',y)

end.

Объяснение:

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота