akmal8606
17.02.2022 02:28

Написать программу, запрашивающую с клавиатуры целые числа и определяю-щую максимальное и минимальное из них. окончание ввода – число 0. протестиро-вать программу для последовательности: -3 5 6 -11 24 -1 0. паскаль

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Nadya0210
15.06.2020 23:46


uses crt;
var x,min,max:integer;
begin
clrscr; min:=0;max:=0;
Writeln('Write x = ');
readln(x);
min:=x;
max:=x;
while x<>0 do
begin
readln(x);
if ((min > x) and (x<>0)) then min:=x;
if ((max < x) and (x<>0)) then max:=x;
end;
writeln('max = ',max);
writeln('min = ',min);
readln
end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота