IbraevaLisa
22.12.2022 21:21

Паскаль Массив из десяти элементов заполнили, а потом изменили. Чему будет равна сумма значений элементов массива после выполнения фрагмента программы?

for i := 1 to 10 do
A[i]:=i + 2;
for i := 2 to 10 do
A[i]:= A[i - 1];

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
nazipovadk
24.10.2021 12:37
№1
а) Результат выполнения: вывод p=75.
б) Условие: Вычислить произведение элементов массива A , кратных 5
в) См. вложение.

№2
//PascalABC.Net 3.2
begin
var a:=arrrandom (20, -10, 50); a.Println;
for var i:=0 to 19 do if (a[i] mod 5)<0 then print(a[i]);
end.

№3
begin
var t:=arrRandom(85, -40, 50);
var sum:=0;
for var i:=0 to 84 do if (t[i] mod 2)=0 then sum+=t[i];
t.Println;
for var i:=0 to 84 do if (t[i] mod 2)=0 then t[i]:=sum;
t.Println; write ('Сумма=', sum);
end.

№4
begin
var x:=readreal('Введите x =');
var y:=readreal('Введите y =');
print ('D =', min(x-21,5*y+1)-min(x*5 +2, y*4-10));
end.
Хоть с чем-то 1. для следующего фрагмента программы: program prog; uses crt; const a: array[1..8] of
0,0(0 оценок)
Ответ:
gptisveto
22.02.2022 16:58

Найти сумму первых 10 натуральных чисел кратных 3.Найти произведение первых 8 натуральных чисел кратных 7.Вывести первые 25 натуральных четных чисел.Вывести первые 15 натуральных чисел кратных 5.Ввести четное число с клавиатуры. Разделить его на 2 до тех пор, пока оно не станет равно1.Ввести число с клавиатуры. Вычитать от него 1, пока оно не станет равным 0.Ввести число с клавиатуры. Прибавлять к нему 5, до тех пор пока оно не станет больше самого себя в 10 раз.Ввести число с клавиатуры. Отнимать от него 2, до тех пор пока оно не станет меньше самого себя вдвое.Ввести натуральное число с клавиатуры. Найти количество его цифр.Ввести натуральное число с клавиатуры. Найти сумму его цифр.Ввести число с клавиатуры. Вывести все его цифры.Вывести 15 первых чисел, так чтобы каждое последующее было в 2 раза больше предыдущего.Вывести 10 первых чисел, так чтобы каждое последующее было на 10 больше предыдущего.Вывести 20 первых чисел, так чтобы каждое последующее было на 1 меньше предыдущего. Первое число - 25.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота