oksana341
19.11.2020 14:00

напишите программу которая в последовательности чисел заканчивающуюся нулем определяет среднее арифметическое четных чисел кратных 3 и трехзначных, ПИТОН

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
snysor
09.03.2021 17:05

summ = 0

count = 0

while 1:

   a = int(input())

   if a == 0:

       break

   elif len(str(abs(a))) == 3 and a % 2 == 0 and a % 3 == 0:

       summ += a

       count +=1

print(summ/count)

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота