akyngazy96
13.01.2023 11:54

Составьте программу для решения следующей задачи: Даны значения всех сторон двух треугольников,определите равновеликие ли эти треугольники?(равны ли их площади)
Формула нахождения площади треугольника S=1/2ah

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
famin19810
30.01.2022 06:10
Uses
  Crt;
var
  i,n:integer;
  a,s:real;
begin
  Writeln('Вычисление среднего арифметического');
  Writeln('последовательности действительных чисел');
  Write('Введите количество чисел последовательности ->');
  Readln(n);
  Writeln('Введите последовательность. После ввода каждого числа нажмите Enter');
  s:=0;
  for i:=1 to n do
  begin
    Read(a);
    s:=s+a
  end;
  Writeln('Среднее арифметическое введенной последовательности: ',s/n);
  Write('Для завершения работы программы нажмите Enter');
  Readkey
end.

Тестовое решение:
Вычисление среднего арифметического
последовательности действительных чисел
Введите количество чисел последовательности ->5
Введите последовательность. После ввода каждого числа нажмите Enter
5.4
7.8
3.0
1.5
2.3
Среднее арифметическое введенной последовательности: 4
Для завершения работы программы нажмите Enter

Для версии Pascal.ABC.Net:
var
  i,n:integer;
  a,s:real;
begin
  Writeln('Вычисление среднего арифметического');
  Writeln('последовательности действительных чисел');
  Write('Введите количество чисел последовательности ->');
  Readln(n);
  Writeln('Введите последовательность. После ввода каждого числа нажмите Enter');
  s:=0;
  for i:=1 to n do
  begin
    Read(a);
    s:=s+a
  end;
  Writeln('Среднее арифметическое введенной последовательности: ',s/n)
end.
 
0,0(0 оценок)
Ответ:
vilyamsuper
23.08.2022 13:21
Язык не задан, поэтому я напишу только алгоритм.
1) Вводим массив A(10, 10)
2) Открываем пустой массив из одной строки B(10)
3) flag = 0
4) Цикл по i от 1 до 9
4.1) Цикл по k от 1 до 10 (по столбцам)
4.1.1) Копируем i-ую строку из массива А в массив В
4.2) Конец цикла по k
4.3) Цикл по j от i + 1 до 10 (по строкам)
4.3.1) Цикл по k от 1 до 10 (по столбцам)
4.3.1.1) Сравниваем j-ую строку массива А и массив В
4.3.2) Конец цикла по k
4.3.3) Если строки равны, то выводим их на экран.
4.4) Конец цикла по j
5) Конец цикла по i
6) Конец
Коротко говоря, алгоритм такой.
Сравниваем 1 строку со всеми от 2 до 10. Если строки совпали - выводим их на экран. Можно вывести только номера, можно сами строки.
Переходим ко 2 строке. Ее сравниваем от 3 до 10. И так далее.
Последнюю 9 строку сравниваем только с 10.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота