SMokKK
21.06.2020 02:13

1. Составьте программу закрашивания клеток, отмеченных звездочкой. Начальное положение Робота - где-то в центре поля.​

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
innahot418
26.02.2021 10:05

print('Это действие будет повторяться 10 раз!')

print('Это действие будет повторяться 10 раз!')

print('Это действие будет повторяться 10 раз!')  

print('Это действие будет повторяться 10 раз!')

print('Это действие будет повторяться 10 раз!')

print('Это действие будет повторяться 10 раз!')

print('Это действие будет повторяться 10 раз!')

print('Это действие будет повторяться 10 раз!')

print('Это действие будет повторяться 10 раз!')

print('Это действие будет повторяться 10 раз!')

Объяснение:

Команда print отвечает за вывод текста, итого текст будет выводиться 10 раз

0,0(0 оценок)
Ответ:
Valerie954
13.08.2021 18:29

Program asd;

uses crt;

var a,b,c,max:integer; r:real;

begin

 Write('Введите число A: '); 

Readln(a);

 Write('Введите число B: '); 

Readln(b); 

Write('Введите число C: '); 

Readln(c); 

If  a>=b then max:=a

 else 

 max:=b;   

 If c>max then

max:=c; 

r:=a+b+c;

 If (A>B) and (B>C) and (C>0) then

 Writeln('A= ',a*2,' B= ',b*2,' C= ',c*2);

 If (A<0) and  (B<0) and (C<0) and (A<>B) and (B<>C) and (C<>A)  then

 begin   

A:=max;   

 B:=max; 

 C:=max; 

Writeln('A= ',a,' B= ',b,' C= ',c); 

  end   

else   

 Writeln('Symma: ',r);

end

Объяснение:

Program asd;

uses crt;

var a,b,c,max:integer; r:real;

begin

 Write('Введите число A: '); 

Readln(a);

 Write('Введите число B: '); 

Readln(b); 

Write('Введите число C: '); 

Readln(c); 

If  a>=b then max:=a

 else 

 max:=b;   

 If c>max then

max:=c; 

r:=a+b+c;

 If (A>B) and (B>C) and (C>0) then

 Writeln('A= ',a*2,' B= ',b*2,' C= ',c*2);

 If (A<0) and  (B<0) and (C<0) and (A<>B) and (B<>C) and (C<>A)  then

 begin   

A:=max;   

 B:=max; 

 C:=max; 

Writeln('A= ',a,' B= ',b,' C= ',c); 

  end   

else   

 Writeln('Symma: ',r);

end

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота