Поля5021
14.11.2022 13:30

Напишите программу на языке Паскаль:

Y={2*x2-4, если x<3 5*x2+x, если x>3

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
даша3635
16.07.2022 06:54

#include <stdio.h>

#include <math.h>

float eps = 0.000001;

int main()

{

float n; scanf("%f", &n);

float a[n];

for (int i=0;i<n;i++)

scanf("%f", a[i]);

char toCopy = 1;

for (int i=1;i<n;i+=2)

if (abs(round(a[i]) - a[i]) > eps)

{toCopy = 0; break;}

if (toCopy)

int b[n/2];

for (int i=n-(n%2), j=0;j<n/2;i-=2, j++)

b[j] = (int)a[i];

}

Объяснение:

Предполагаю, что сначала указывается количество элементов исходного массива. Далее происходит все то, что вы описали. eps - погрешность для определения целого числа, чем оно меньше - тем точнее числа будут определяться как дробные

0,0(0 оценок)
Ответ:
larisa114
15.05.2021 07:51
var a: array[1..2,1..4] of real;
    b,c: string; 
    d,x,y: real;
    i,j: integer;
begin
   b:='ABCD';  c:='xy';
   writeln('трапеция ABCD');
   for i:=1 to 4 do
   begin
     writeln('координаты точки ',b[i],': ');
     for j:=1 to 2 do
     begin
       write('   ',c[j],i,' = ');
       readln(a[j,i]);
     end;  
   end;  
   x:=(a[1,3]-a[1,2]+a[1,4]-a[1,1])/2;
   y:=(a[2,3]-a[2,2]+a[2,4]-a[2,1])/2;
   d:=sqrt(x*x+y*y);
   writeln('длина средней линии:  ',d:5:2);
end.

ввод - вывод

трапеция ABCD
координаты точки A: 
   x1 = 3
   y1 = 2
координаты точки B: 
   x2 = 5
   y2 = 5
координаты точки C: 
   x3 = 9
   y3 = 5
координаты точки D: 
   x4 = 10
   y4 = 2
длина средней линии:   5.50
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота