ududufivuv
21.05.2023 00:34

С++ 1. Задача ANKETA

Составить программу ANKETA, которая вводит с клавиатуры

анкетные данные пользователя программы (фамилия, имя,

отчество, пол, дата рождения, адрес, номер телефона,

место учебы, класс, хобби) и выводит их

на экран в отформатированном виде.

Пример работы программы:

Фамилия?= Билл

Имя?= Гейтс

Отчество?= Иванович

Пол?= мужской

Дата рождения?= 1.01.1900

Адрес?= One Microsoft Way, 1, NY, USA

Номер телефона?= 1-2-3-4-5

Место учебы?= -

Класс?= -

Хобби?= программирование

<и далее с первой строки экрана>

А Н К Е Т А

Фамилия Имя Отчество

Гейтс Билл Иванович

Пол Дата рождения Номер телефона

мужской 1.01.1900 (093)839 33 55

Адрес

One Microsoft Way, 1, NY, USA

Место учебы Класс



Хобби

программирование

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
skorospelovana
27.06.2020 15:25

Ошибки в программе:

Program primer - не хватает точки с запятой

Var a,b: integer;

Begin ; - не ошибка, необязательная точка с запятой

 ReadLn( a,b); - не ошибка, лишний пробел после скобки, здесь и дальше не хватает пробелов между аргументами функций, знаками

 s=a+b; - не хватает двоеточия в :=

 m:=a*b;

 d:=a:b; - переменная d не была описана; деление - это /

 WriteLn(s);

 WriteLn(m);

 WriteLn(d)

End - не хватает точки.

 

Исправленная программа:

Program primer;

Var a, b: integer;

  d: real;

Begin

  ReadLn(a, b);

  s := a + b;

  m := a * b;

  d := a / b;

  WriteLn(s);

  WriteLn(m);

  WriteLn(d)

End.

0,0(0 оценок)
Ответ:
AlexFireStreamGun
15.07.2020 04:17
1+1=10 (ноль пишем, 1 - переходит в старший разряд)
Вообще все можно представить так - 1-самая старшая цифра в двоичной с.с. (В десятичной - это 9. При прибавлении в десятичной с.с. к 9 мы получаем 10, так происходит во всех с.с. Только в двоичной самая старшая 1 и, при прибавлении к ней 1 мы получаем также 10)
  101011
+101010
 1010101
Аналогично при вычитании. Представим число в десятичной с.с, например,1000. Если из него нужно вычесть 1, то мы заберем нужный нам разряд  у 1. Тогда последний 0 превратится в 10, а все остальные 0 в 1. 
 11101
-  1111
   1110
Ну, а умножение - это тот же процесс сложения. 
               10110
                 1111
               10110
          +  10110
            10110
          10110
        101001010
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота