avgustreykh14
26.12.2022 03:27

Задача №112294. Три минимума Напишите программу, которая находит в массиве три минимальных элемента, то есть три первых элемента массива после сортировки по возрастанию.

Входные данные
Первая строка содержит размер массива N . Во второй строке через пробел задаются N чисел – элементы массива. Гарантируется, что 3 < N ≤ 10000 .

Выходные данные
Программа должна вывести в одной строке три минимальных элемента массива в порядке возрастания, разделив их пробелами.

Примеры
входные данные
6
1 2 3 4 0 5
выходные данные
0 1 2
НА С++

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Эрбол11111
09.11.2022 10:25

Видеоурок 

Текстовый урок 

Тесты

Во к уроку

На предыдущих уроках мы подробно рассмотрели внутреннее устройство компьютера – его комплектующие и основные внутренние части. Однако для того, чтобы рассматривать современный компьютер как полноценное средство обработки информации (то есть устройство, выполняющее конкретные прикладные задачи), необходимо учесть также и его программное обеспечение, то есть все приложения и службы, установленные на данный компьютер. На сегодняшнем уроке вы познакомитесь с различными видами программного обеспечения, узнаете, для чего нужна та или иная программа и научитесь их устанавливать.

Введение

Что же такое программное обеспечение компьютера? Рассмотрим этот термин подробнее.

Программное обеспечение (ПО) – это все компьютерные программы, процедуры и соответствующая документация и данные, относящиеся к функционированию данной компьютерной системы.

Всё программное обеспечение можно разделить на следующие типы

Виды программного обеспечения

1. Системное программное обеспечение. Это такие программы, которые входят в состав операционной системы и являются составной ее частью. Обычно они обеспечивают управление компонентами компьютерной системы, такими как процессор, оперативная память, устройства ввода-вывода а также сетевое оборудование. Типичным примером для системной программы является драйвер. Драйвер– это компьютерная программа, при которой другие программы получают доступ к аппаратному обеспечению некоторого устройства (например, к принтеру, сканеру, видеокарте и т. д.). Драйверы являются неотъемлемой составляющей операционной системы – совокупность программ, организующих согласованную работу всех модулей компьютера.

2. Обслуживающие программы.К ним относятся те программы, которые выполняют вс обслуживающие либо сервисные функции, например архиваторы, антивирусы и программы для обслуживания жесткого диска компьютера. Программы такого типа также называют утилитами (от англ. utilize – «использовать»).

3. Прикладные программы –это обширный класс программ, предназначенный для решения отдельных определенных пользователем задач, связанных с обработкой данных в определенной области деятельности. К ним можно отнести, например, текстовые, графические, аудио, видео-редакторы, средства управления базами данных, обучающие, тестовые, игровые программы и т. д.

Большинство программ на сегодняшний день создаются с привязкой к конкретной операционной системе (например, Windows, Linux, Android, MacOS) и т. д. Этот факт необходимо обязательно учитывать при выборе той или иной программы.

Перед запуском программы ее нужно правильным образом инсталлировать, то есть установить на данный компьютер. Существуют специальные программы-инсталляторы, например Rpm для ОС Linux или Windows Installer для Windows. Очень часто программы-инсталляторы входят в состав операционной системы по умолчанию. Инсталлировать программу – означает установить (распаковать) все ее значимые файлы в соответствующие директории операционной системы. Для того чтобы программа инсталлировалась верно, она должна содержать так называемый дистрибутив. Дистрибутив программы (от англ. distribute – распределять) – это совокупность компонентов, необходимых для ее установки (инсталляции). Дистрибутив операционной системы обычно содержит в себе программы для начальной инициализации системы.

0,0(0 оценок)
Ответ:
Miraflores18
15.12.2021 13:48

Объяснение:

program treugolnik;

uses crt;

var

x1, y1, x2, y2, x3, y3, p:real;

function dlina(a1,b1, a2,b2:real):real;

begin

dlina:=sqrt(sqr(a1-a2)+sqr(b1-b2));

end;

begin

writeln('Введите координаты 1-ой вершины');

write('x='); readln(x1);

write('y='); readln(y1);

writeln('Введите координаты 2-ой вершины');

write('x='); readln(x2);

write('y='); readln(y2);

writeln('Введите координаты 3-ей вершины');

write('x='); readln(x3);

write('y='); readln(y3);

p:=dlina(x1,y1,x2,y2)+dlina(x1,y1,x3,y3)+dlina(x2,y2,x3,y3);

writeln('Периметр=',p);

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота