azino776
30.08.2021 17:44

Напишите программу, которая определяет, является ли переданное ей натуральное число простым (простое число делится только на 1 и само на себя). ОБЯЗАТЕЛЬНО СЕЛАТЬ С РЕКУРСИЕЙ НА PYTHON!

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
ЕленаЧернова
22.02.2021 17:10

import sys

sys.setrecursionlimit(22000)

def func(a, i):

 if i*i<a:

   if a>=i:

     if a != i and a%i != 0:

       i+=1

       return(func(a, i))

     elif a == i:

       return ('YES')

     else:

       return('NO')

   else:

     return('NO')

 else:

   return('YES')

   

i = 2

a = int(input())

print(func(a,i))

вот, первые две строчки можете убрать, если на проверки вводятся не слишком большие числа.

буду благодарен, если отметите лучшим решением:)

Объяснение:

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота