David3464
22.01.2021 11:46

1) составьте программу которая вычисляет значение выражения k = x³-4xy (x+y²) 2) составьте программу, которая вычисляет количество секунд в заданном количестве часов по формуле c=3600 * h


1) составьте программу которая вычисляет значение выражения k = x³-4xy (x+y²) 2) составьте программу

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
kupecki
13.12.2022 19:50

#include <iostream>

int main()

{

int n;

float l;

std::cin >> n >> l;

switch (n)

{

case 1:

 std::cout << "Length: " << l / 10;

 break;

case 2:

 std::cout << "Length: " << l * 1000;

 break;

case 3:

 std::cout << "Length: " << l;

 break;

case 4:

 std::cout << "Length: " << l / 1000;

 break;

case 5:

 std::cout << "Length: " << l / 100;

 break;

default:

 break;

}

std::cout << std::endl;

system("pause");

return 0;

}

0,0(0 оценок)
Ответ:
nikitakirillov3
04.03.2023 00:21

1.

использовать Робот

алг 3 полоски

нач

нц пока снизу стена

закрасить

влево

кц

нц пока снизу свободно

влево

кц

нц пока слева свободно

закрасить

влево

кц

закрасить

нц пока слева стена

закрасить

вверх

кц

нц пока слева свободно

вверх

кц

нц пока слева стена

закрасить

вверх

кц

кон

2.

использовать Робот

алг

нач

нц пока сверху стена

закрасить

влево

кц

нц пока сверху свободно

влево

кц

нц пока слева свободно

закрасить

влево

кц

закрасить

нц пока слева стена

закрасить

вниз

кц

нц пока слева свободно

вниз

кц

нц пока слева стена

закрасить

вниз

кц

кон

3.

использовать Робот

алг

нач

нц пока слева стена

вверх

кц

влево

вниз

нц пока справа стена

закрасить

вниз

кц

нц пока справа свободно

вправо

кц

нц пока справа стена

закрасить

вниз

кц

кон

4.

использовать Робот

алг

нач

нц пока сверху стена

вправо

кц

вверх

нц пока слева стена

вверх

кц

влево

вниз

нц пока справа стена

вниз

кц

нц пока слева свободно

закрасить

влево

кц

кон

Объяснение: лишние циклы добавлены в случае изменений условия, а именно разной длины стенок и пропастей

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота