Dasha5746
02.08.2021 15:41

Составьте программу удаления строки и столбца, содержащего максимальный элемент матрицы A (N, N).

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
moon471
28.03.2021 00:42

#include <stdio.h>

#include <stdlib.h>

#include <locale.h>

#include <time.h>

int main(){

   setlocale(LC_ALL,"rus");

   srand(time(0));

 

   int **array_a;

   int line;

   int column;

   int i, j;

   int min_i;

   int min_j;

 

   printf("Введите размер матрицы: ");

   scanf("%d %d", &line, &column);

   array_a = (int**)malloc(sizeof(int)*line);

   for(i = 0; i < line; i++)

       array_a[i] = (int*)malloc(sizeof(int)*column);

 

   printf("\nИсходный массив:\n");

   for(i = 0; i < line; i++){

       for(j = 0; j < column; j++){

           array_a[i][j] = rand()%10;

           printf("%d ", array_a[i][j]);

       }

       printf("\n");

   }

 

   min_i = 0;

   min_j = 0;

   

   for(i = 0; i < line; i++){

       for(j = 0; j < column; j++){

           if(array_a[i][j] < array_a[min_i][min_j]){

               min_i = i;

               min_j = j;

           }

       }

   }

 

   for(i = 0; i < line; i++){

       for(j = min_j; j < column - 1; j++){

           array_a[i][j] = array_a[i][j+1];

       }

   }

 

   for(i = min_i; i < line - 1; i++){

       for(j = 0; j < column - 1; j++){

           array_a[i][j] = array_a[i+1][j];

       }

   }

 

   printf("\nРезультат:\n");

   for(i = 0; i < line - 1; i++){

       for(j = 0; j < column - 1; j++){

           printf("%d ", array_a[i][j]);

       }

       printf("\n");

   }

   return 0;

}

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота