Lololiplolpjvfhsbf
22.06.2022 03:01

написать программу на C++ Сумма больших

С клавиатуры вводится несколько чисел.

Найдите сумму чисел, превышающих 4.

Формат ввода
В первой строке вводится количество чисел n. 0 ≤ n ≤ 1000.

В следующей строке вводятся подряд n чисел ai через пробел. 0 ≤ ai ≤ 1000.

Формат вывода
Выведите сумму чисел, больших 4. Если таких чисел нет, выведите 0.

Пример
Ввод Вывод
4 5
2 5 3 4

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
сашулька00001
28.03.2021 23:53

#include <iostream>

#include <cmath>

using namespace std;

int main()

{

int n, x = 0;

int *a = new int[n];

printf("Enter the number of digits\n");

cin >> n;

printf("Enter numbers\n");

for(int i = 0; i < n; ++i)

{

 cin >> a[i];

 if(a[i] > 4)

 x+=a[i];

}

printf("%d",x);

delete [] a;

}

Объяснение:

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота