belevich031197
07.06.2022 10:02

Напишите программу, которая считывает три числа и выводит их сумму.


Напишите программу, которая считывает три числа и выводит их сумму.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
polli11092002
15.09.2022 03:59

Т.к. требуется использовать цикл until, то значит требуется код на языке Паскаль.

1) цикл for

program p_for

var

  p:  real;

  i, n: integer;

begin

  readln(n);

  p := 1;//начальное значение

  for i := 1 to n do  

     p := p * i;

  writeln(p);

end.  

2) цикл while

program p_while

var

  p:  real;

  i, n: integer;

begin

  readln(n);

  i := 1;

  p := 1;//начальное значение

  while i <= n do  

  begin

     p := p * i;

     i := i + 1;

 end;

 writeln(p);

end.  

3) цикл until

program p_until

var

  p:  real;

  i, n: integer;

begin

  readln(n);

  i := 1;

  p := 1;//начальное значение

  repeat

     p := p * i;

     i := i + 1;

  until i > n;

  writeln(p);

end.  

Объяснение:

0,0(0 оценок)
Ответ:
Fobsliza
19.12.2020 15:53
// PascalABC.NET 3.3, сборка 1627 от 27.01.2018
// Внимание! Если программа не работает, обновите версию!

begin
  var n:=4;
  var xp:=new real[n];
  var yp:=new real[n];
  Writeln('Введите парами координаты четырех вершин');
  for var i:=0 to n-1 do Read(xp[i],yp[i]);
  var (x,y):=ReadReal2('Введите координаты точки:');
  var (i,j,c):=(0,n-1,False);
  while i<n do begin
    if ((yp[i]<=y) and (y<yp[j]) or (yp[j]<=y) and (y<yp [i]))
      and (x<(xp[j]-xp[i])*(y-yp[i])/(yp[j]-yp[i])+xp[i]) then c:=not c;
    j:=i;
    i+=1;
    end;
  if c then Writeln('Внутри')
  else Writeln('Не внутри')
end.

Примеры
Введите парами координаты четырех вершин
 1 4 6 9 9 6 4 1
Введите координаты точки: 1.5 1.6
Не внутри

Введите парами координаты четырех вершин
1 4 6 9 9 6 4 1
Введите координаты точки: 4 7
Внутри
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота