Написать программу,которая в слове находит повторяющиеся буквы и уделает их.Без массивов,с использованием строковых операций по типу s.replace для удаления. Максимально понятно.Python.
for i := 1 to n do begin s1 := s1 + i; s2 := s2 + sqr(i); if i mod 2 = 0 then s3 := s3 + i; end;
for i := 10 to 99 do s4 := s4 + i;
writeln('Сумма первых n натуральных чисел: ', s1); writeln('Сумма квадратов первых n натуральных чисел: ', s2); writeln('Сумма всех четных чисел: ', s3); writeln('Сумма всех двухзначных чисел: ', s4); end.
Попробуй так Uses Graph, CRT; var d,r,r1,r2,rr,k, x1,y1,x2,y2,x01,y01: Integer; Xasp,Yasp : Word;
begin {Инициируем графику} d := detect; InitGraph(d, r, ' ') ; k:= GraphResult; if k <> grOK then WriteLn(GraphErrorMSG(k)) else begin {Определяем отношение сторон и размеры экрана} x1 := GetMaxX div 2; y1 := GetMaxY div 2; GetAspectRatio(Xasp, Yasp);
{Готовим вывод стрелок} SetWriteMode(XORPut); SetLineStyle(SolidLn,0,ThickWidth); r := 0; {Счетчик минут в одном часе}
{Цикл вывода стрелок} repeat for k := 0 to 59 do {k = минуты} if not KeyPressed then begin {Координаты часовой стрелки} x2 := x1+Round(0.85*r1*sin(2*pi*r/60/12)); y2 := y1-Round(0.85*r1*Xasp*cos(2*pi*r/60/12)/Yasp);
{Изображаем стрелки} Line(x1,y1,x2,y2); Line(x1,y1,x01,y01); Delay(100); {Для имитации реального темпа нужно установить задержку 60000} {Для удаления стрелок выводим их еще раз!} Line(x1,y1,x01,y01); Line (x1,y1,x01,y01 ) ;
{Наращиваем и корректируем счетчик минут в часе} inc(r); if r=12*60 then r := 0 end until KeyPressed; if ReadKey=#0 then k:=ord(ReadKey); CloseGraph; end end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку