alexlion99alex
20.09.2022 04:15

Составить программу находящую значение функции у заданной формулой * (язык программирования python)


Составить программу находящую значение функции у заданной формулой * (язык программирования python)

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
green121
18.04.2020 23:14
Единицы измерения информации 
В 1 бит можно записать один двоичный символ.
1 байт = 8 бит
В кодировке ASCII в один байт можно записать один 256 символьный код
В кодировке UNICODE один 256 символьный код занимает в памяти два байта
1 килобайт = 1024 байт
1 мегабайт = 1024 килобайт
1 гигабайт = 1024 мегабайт
1 терабайт = 1024 гигабайтФормула Хартли 2 i = N где i- количество информации в битах, N - неопределенностьТаблица степеней двойки, которая показывает сколько информации можно закодировать с бит i012345678910N=2 i12481632641282565121024Чтобы вычислить информационный объем сообщения надо количество символов умножить на число бит, которое требуется для хранения одного символа

Например: двоичный текст 01010111 занимает в памяти 8 бит 
Этот же текст в кодировке ASCII занимает 8 байт или 64 бита 
Этот же текст в кодировке UNICODE занимает 16 байт или 128 бит. 



0,0(0 оценок)
Ответ:
Умник1997337
05.04.2020 22:41
// PascalABC.NET 3.3, сборка 1627 от 27.01.2018
// Внимание! Если программа не работает, обновите версию!

№6

begin
  var a:=ArrRandom(ReadInteger('n='),-99,99).Println;
  Writeln('[',a.Min,';',a.Max,']')
end.

Пример
n= 13
72 -77 -88 -99 -2 -61 67 40 -30 -28 91 -56 29
[-99;91]

№9

begin
  var a:=ReadArrReal('Вводите:',ReadInteger('n='));
  Writeln('Положительных: ',a.Where(t->t>0).Count);
  Writeln('Отрицательных: ',a.Where(t->t<0).Count);
  Writeln('Нулевых: ',a.Where(t->t=0).Count)
end.

Пример
n= 10
Вводите: 3.7 12.6 -4 0 -13.2 0.7 0 14 2.12 0.004
Положительных: 6
Отрицательных: 2
Нулевых: 2

№16

begin
  var a:=Arr(-3.7,-3.1,-2.3,-1.6,-0.9,-0.2,0.5,1.2,1.9,2.6,3.3,4.0,4.2,5.4,
      1.92,1.76,1.52,1.26,0.95,0.45,0.71,1.10,1.38,1.61,1.82,2.00,2.05,2.32);
  var d:=a.Length div 2;
  for var i:=0 to d-1 do Writeln(a[i]:5:2,a[i+d]:20:3)
end.

Результат
-3.70               1.920
-3.10               1.760
-2.30               1.520
-1.60               1.260
-0.90               0.950
-0.20               0.450
 0.50               0.710
 1.20               1.100
 1.90               1.380
 2.60               1.610
 3.30               1.820
 4.00               2.000
 4.20               2.050
 5.40               2.320

№19

begin
  var n:=ReadInteger('n=');
  var a:=ArrRandom(n,-50,50); a.Println;
  var i:=1;
  while i<=n do begin
    Print(a[i-1]);
    i*=2
    end;
  Writeln
end.

Пример
n= 17
-43 -41 -37 -43 12 45 -34 -19 -38 33 -34 39 -40 33 -46 4 39
-43 -41 -43 -19 4
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота