tyankitty
02.02.2022 11:09

решите на языке питон Как известно, самая лучшая школа на свете — Школа Программистов. Мы готовы повторять это снова и снова. Но пусть это будет делать цикл (n раз). Формат входных данных Дано одно целое число n (1 ≤ n ≤ 100).

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
KUROCHKA777
20.06.2020 22:17
// PascalABC.NET 3.2, сборка 1417 от 28.03.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var a:=ArrRandom(ReadInteger('n='),-20,20); a.Println;
  var imin:=a.IndexMin;
  Writeln('Номер минимального элемента- ',imin+1);
  Writeln('Элементов, равных минимальному- ',
      a.Where(x->x=a[imin]).Count-1)
end.

Пример
n= 50
-13 17 18 10 -6 13 16 -12 -15 10 18 -7 -20 18 14 14 11 20 4 4 -10 6 -20 11 -2 4 7 -3 -20 -18 -6 11 -15 -8 16 11 -13 3 -5 2 6 7 -10 11 8 19 1 -11 16 -10
Номер минимального элемента- 13
Элементов, равных минимальному- 2
0,0(0 оценок)
Ответ:
garachuk75
28.07.2022 19:40
Первое задание, программа задает массив, сортирует его, затем сравнивает элемент с последующем

uses crt;
var
a:array[1..100] of integer;
i,j:integer;
procedure swap(var x,y: integer);
   var t: integer;
 begin
    t := x;
    x := y;
    y := t
 end;
begin
for i:=1 to 100 do a[i]:=random(100);
for j:=1 to 99 do
for i:=1 to 100-j do if a[i] > a[i+1] then swap(a[i],a[i+1]);
for i:=1 to 99 do if a[i]=a[i+1] then
begin
writeln(a[i]);
writeln(a[i+1]);
end;
end.

Второе задание. Программа также сортирует и сравнивает элементы

uses crt;
var
a:array[1..100] of integer;
i,j:integer;
procedure swap(var x,y: integer);
   var t: integer;
 begin
    t := x;
    x := y;
    y := t
 end;
begin
for i:=1 to 100 do a[i]:=random(100);
for j:=1 to 99 do
for i:=1 to 100-j do if a[i] > a[i+1] then swap(a[i],a[i+1]);
for i:=1 to 99 do if a[i]<>a[i+1] then
begin
writeln(a[i]);
end;
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота