deloranka
20.02.2020 05:39

Дан массив a, состоящий из n целых неотрицательных чисел. Ваша задача — выписать нечётные элеметы массива a в начало массива b, а затем дополнить массив b нулями до размера n. Формат входных данных
В первой строке входных данных находится натуральное число n (n≤500) — количество элементов массива.
Во второй строке вводятся n целых неотрицательных чисел, разделённых пробелами — элементы этого массива. Элементы массива не превосходят 1000.

Формат выходных данных
Выведите на экран n целых неотрицательных чисел, разделённых пробелами — элементы массива b.
входные данные
4
1 3 3 7

5
4 20 412 3 2
выходные данные
1 3 3 7

3 0 0 0 0

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
dashkastroga
23.08.2021 22:27
Задание 1
Информационный объем I = 44100 Гц * 5 * 60 с * 16 бит = 211680000 бит = 26460000 байт = 25839,84375 Кбайт = 25,23422241210938 Мбайт

Задание 2
I = 1,3 Мбайт t = 1 мин Частота дискретизации v = 1,3 * 1024 * 1024 * 8 бит / 60 с / 8 бит = 22719,147 Гц

Задание 3
I = 5.1 Мбайт, t = 2 минуты, v = 22050 Гц Разрядность аудиоадаптера i = 5.1 * 1024 * 1024 * 8 бит / (2 * 60) с / 22050 Гц = 16,1685 бит (округленно 16 бит)

Задание 4
I = 0.01 Гбайт, i = 16 бит, v = 44100 Гц Время t = 0,01 * 1024 * 1024 * 1024 * 8 бит / 16 бит / 44100 Гц = 121 с (округляем до 120 с)
0,0(0 оценок)
Ответ:
Польбощь
10.01.2021 03:34
var   s : string[50];
  i, j, k : word;  
 f : boolean;  
function isSpace(ch : char) : boolean;
begin   isSpace := false;  
if ch = ' ' then isSpace := true;
end;  
begin   f := false;  
   repeat     j := 0;
    writeln('введите строку, состоящую из 2 слов');
    readln(s);    
for i := 1 to length(s) do    
   if isSpace(s[i]) then  
    begin    
     inc(j);      
   k := i;       end;
     if j =1 then f := true;
    until f;    
write(copy(s, k + 1, length(s)), ' ', copy(s, 1, k - 1)); 
end.
недавно такую писала :)
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота