ВикторияТуп
10.03.2022 23:19

написать программу из модуля 7 получения прописных букв с использованием поразрядного оператора И

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
morozovasanya
27.07.2021 22:27
{1}

const
 s:string = 'IVXLCDM';
var
 x,i,l,k:integer;

begin
 read(x); {x < 4000}
 l := 1000;
 i := 4;
 for i := 4 downto 1 do
   begin
   k := x div l mod 10;
   if k = 9 then
     write(s[i*2-1],s[i*2+1])
   else
   if k = 4 then
     write(s[i*2-1],s[i*2])
   else
     begin
     if k >= 5 then
       begin
       write(s[i*2]);
       k := k - 5
       end;
     for k := k downto 1 do
       write(s[i*2-1])
     end;
   l := l div 10
   end
end.

{2}

const
 eps = 1e-10;
 stp = 500;

var
 a: real;
 l,r,m: real;
 extreme: real;

function f(x:real):real;
begin
 f := a*x - exp(-x)
end;

begin
 read(a);
 if a = 0 then
   writeln('No solutions')
 else
 if a > 0 then
   begin
   l := 0;
   r := stp*2;
   while f(r) <= 0 do
     begin
     l := l + stp;
     r := r + stp
     end;
   while r - l > eps do
     begin
     m := (l + r)/2;
     if f(m) > 0 then
       r := m
     else
       l := m
     end;
   m := (l + r) / 2;
   writeln('Solution: ',m:0:5);
   writeln('e^-x = ',exp(-m):0:5);
   writeln('ax = ',a*m:0:5)
   end
 else
   begin
   extreme := ln(-1/a);
   if f(extreme) < 0 then
     writeln('No solutions')
   else
   if f(extreme) = 0 then
     writeln('Solution: ',extreme)
   else
     begin
     {writeln('Extreme: ',extreme);}
          l := extreme;
     r := 0;
     while r - l > eps do
       begin
       m := (l + r)/2;
       if f(m) < 0 then
         r := m
       else
         l := m
       end;
     m := (l + r) / 2;
     writeln('Solution 1: ',m:0:5);
     writeln('e^-x = ',exp(-m):0:5);
     writeln('ax = ',a*m:0:5);
     writeln;
          r := extreme;
     l := r - stp*2;
     while f(l) > 0 do
       begin
       l := l - stp;
       r := r - stp
       end;
     while r - l > eps do
       begin
       m := (l + r)/2;
       if f(m) > 0 then
         r := m
       else
         l := m
       end;
     m := (l + r) / 2;
     writeln('Solution 2: ',m:0:5);
     writeln('e^-x = ',exp(-m):0:5);
     writeln('ax = ',a*m:0:5)
           end
   end
end.

{3}

var
 c: array [1..12] of 0..7;
 x,i,k: integer;

begin
 read(x);
 k := x;
 i := 0;
 repeat
   i := i + 1;
   c[i] := k mod 8;
   k := k div 8
 until k = 0;
 for i := i downto 1 do
   write(c[i])
end.
0,0(0 оценок)
Ответ:
VAI81416
06.02.2022 21:28

Выступление перед аудиторией порой вызывает немало хлопот даже у людей опытных, не говоря уже о новичках, делающих «первые шаги». Успех выступления зависит от многих факторов, где содержание доклада играет одну из ключевых ролей.

Когда докладчик часто заглядывает, а то и напропалую читает текст, не отрываясь от него ни на минуту, между ним и публикой не происходит контакта. Внимание аудитории быстро рассеивается, направляясь на что угодно, только не на докладчика.

Что же теперь выучить весь текст наизусть, с вы? А если речь идет о защите дипломной работы в какой-нибудь. Вовсе нет. Мало кто располагает достаточным количеством времени, чтобы запомнить всю речь. Кроме того многие доклады изобилуют цифрами, в которых лучше не ошибаться. Получается, что текст все же лучше читать. Но что в таком случае делать, чтобы не потерять визуальный контакт с публикой? Лучше всего прибегнуть к приему, которым пользуются дикторы телевидения. Для этого нужно читать лишь первые слова предложения, запоминая последующие, которые уже следует произносить, глядя в зрительный зал.

Естественно, для того чтобы выступать уверенно, необходимо хорошо знать содержание текста, поэтому одной репетицией здесь не обойтись. Следует несколько раз прочитать доклад, причем делая это вслух, громко и четко.

Как правило, докладчику для выступления предоставляют кафедру, на которой можно удобно разместить текст доклада. При желании текст можно взять в руку. Только, в этом случае, заглядывать в текст следует как можно реже.

Объяснение:

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота