NikNameXxX
03.08.2021 09:13

Напишите программу, которая переводит число (возможно, отрицательное), записанное в шестнадцатеричной системе, в десятичную систему. Входные данные Входная строка содержит шестнадцатеричную запись числа N ( 1 ≤ | N | < 10 9 ). Выходные данные Программа должна вывести десятичную запись этого числа

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
BlaBla552
12.05.2020 20:03
Четырехзначное число в расширенной записи имеет вид
1000a+100b+10c+d
Известно, что первая и последняя цифры одинаковы, отсюда d=a.
Сумма цифр числа равна 16, т.е. 2a+b+c=16  (1)
Если число делится на 2, то оно четное, следовательно "a" может равняться
2, 4, 6, 8.      (2)
Нулю оно равняться не может, поскольку тогда число станет трехзначным.
Если четырехзначное число делится на 11, то модуль разности между суммами цифр, стоящих на четных и нечетных местах должна делиться на 11, т.е. |(a+c)-(a+b)|= |(c-b| делится на 11. Но разность двух однозначных чисел не может превышать 9, поэтому если она делится на 11, то она должна быть равна нулю. Но тогда с=b и число имеет вид
1000a+100b+10b+a.
А уравнение (1) будет выглядеть как
2a+b+b=16; 2a+2b=16; b=8-a  (3)
C учетом (2) можно из (3) получить 4 решения:
a=2, b=6
a=4, b=4
a=6, b=2
a=8, b=0
И это породит 4 возможных кода: 2662, 4444, 6226, 8008.
0,0(0 оценок)
Ответ:
Rasul101231
01.04.2020 13:36
1)
var
a,i:integer;
s:real;
   begin
      readln(a);
        for i:=1 to 5 do
               s:=s+a;
writeln(s:4:0);
end.
2)
var
a,n,i:integer;
s:real;
begin
readln(a,n);
   for i:= 1 to n do
        s:=s+a;
writeln(s:4:0);
end.
3)
var
n,i:integer;
a,s:real;
begin
readln(a,n);
   for i:= 1 to n do
        s:=s+a;
writeln(s:4:2);
end.
4)
const
a='ИНФОРМАТИКА';
var
i,n:integer;
begin
     readln(n);
          for i:=1 to n do
              write(a,' ');
end.
5)
vari,n,a:integer;
p:real;
begin   
       readln(a,n);
              p:=1;       
                       for i:=1 to n do             
                              p:=p*a;
writeln(p);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота