Zazasalka174
11.11.2020 04:29

С++ напишите программу, которая определяет оценку ученика. Программа определяет
оценку на основе следующих правил:
-если >= 90% => оценка = A
-если > = 70% и <90% => оценка = B
-если > = 50% и <70% => оценка = C
-если <50% => оценка = F
Попросите пользователя ввести оценки и распечатать соответствующую оценку​

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Полина260106
13.04.2021 11:01

Немного по-другому

Объяснение:

#include <iostream>

using namespace std;

void main(){

   setlocale(LC_ALL, "Russian");

 

   int x = 0;

 

   cout << "Введите школьную оценку: " << endl;

   cin >> x;

   cout << x;

   switch (x)   {

   case 2: cout << "неудовлетворительно"; break;

   case 3: cout << "удовлетворительно"; break;

   case 4: cout << "хорошо"; break;

   case 5: cout << "отлично"; break;

       switch (x)   {

       case 1:  

       case 2:  

       case 3: cout << "неудовлетворительно"; break;

       case 4:  

       case 5:  

       case 6: cout << "удовлетворительно"; break;

       case 7:

       case 8:

       case 9: cout << "хорошо"; break;

       case 10:  

       case 11:  

       case 12: cout << "отлично"; break;

           if (x > 0 && x <=59)

               cout << "неудовлетворительно" << endl;

           if (x >= 60 && x <=74)

               cout << "удовлетворительно" << endl;

           if (x >= 75 && x <=89)

               cout << "хорошо" << endl;

           if (x >= 90 && x <=100)

               cout << "отлично" << endl;

           switch (x)   {

           case 'F': cout << "неудовлетворительно"; break;

           case 'D':

           case 'E': cout << "удовлетворительно"; break;

           case 'B':

           case 'C': cout << "хорошо"; break;

           case 'A': cout << "отлично"; break;

           }

           cout << endl;

       }

   }

   cout << endl;

}

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота